aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-07-16 21:43:08 +0200
committerPetr Štetiar <ynezz@true.cz>2019-07-17 12:16:29 +0200
commit16ac5c4fbd183398d6a1595f6c87fd85c8668b33 (patch)
treea6d616c3bcd895cc8bc53b727afe573166844b54 /package/devel
parent57d096e2a9bb89a0185d296c0eb8dd76533aa43c (diff)
downloadupstream-16ac5c4fbd183398d6a1595f6c87fd85c8668b33.tar.gz
upstream-16ac5c4fbd183398d6a1595f6c87fd85c8668b33.tar.bz2
upstream-16ac5c4fbd183398d6a1595f6c87fd85c8668b33.zip
perf: simplify the build process
Redirect the build output to PKG_BUILD_DIR instead of copying over complete source code. Build tested on following targets: x86/64 ar7/generic ipq40xx/generic imx6/generic ar71xx/generic ramips/mt7621 ramips/mt7620 sunxi/cortexa7 Run tested on imx6/apalis. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/perf/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/package/devel/perf/Makefile b/package/devel/perf/Makefile
index 3d7110585c..6f31c826e5 100644
--- a/package/devel/perf/Makefile
+++ b/package/devel/perf/Makefile
@@ -36,10 +36,6 @@ define Package/perf/description
perf is the Linux performance monitoring tool
endef
-define Build/Prepare
- $(CP) $(LINUX_DIR)/tools/perf/* $(PKG_BUILD_DIR)/
-endef
-
MAKE_FLAGS = \
ARCH="$(LINUX_KARCH)" \
NO_LIBPERL=1 \
@@ -59,13 +55,13 @@ MAKE_FLAGS = \
LDFLAGS="$(TARGET_LDFLAGS)" \
$(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='') \
WERROR=0 \
+ O=$(PKG_BUILD_DIR) \
prefix=/usr
define Build/Compile
+$(MAKE_FLAGS) $(MAKE) $(PKG_JOBS) \
- -C $(PKG_BUILD_DIR) \
- -f Makefile.perf \
- --no-print-directory
+ --no-print-directory \
+ -C $(LINUX_DIR)/tools/perf
endef
define Package/perf/install