aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2020-08-09 14:42:14 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2020-08-10 23:02:37 +0200
commit0a864f20fb7fae4e3393ef1683d8ab646d2be2f4 (patch)
treeb99fc65d709bce026cb9ff9677a723ea55e5b859 /package/devel
parent2f3d7abccda7742d0e612fe8989ec357ccb36990 (diff)
downloadupstream-0a864f20fb7fae4e3393ef1683d8ab646d2be2f4.tar.gz
upstream-0a864f20fb7fae4e3393ef1683d8ab646d2be2f4.tar.bz2
upstream-0a864f20fb7fae4e3393ef1683d8ab646d2be2f4.zip
bintuils: Pack libctf-nobfd.so in addition
readelf is linked against this library on MIPS64BE This fixes a build problem on MIPS64BE. In addition also explicitly activate it in the configure command. Fixes: 60f595daab45 ("binutils: update to version 2.34") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/binutils/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/devel/binutils/Makefile b/package/devel/binutils/Makefile
index 6ad326efa0..9f7a0724f4 100644
--- a/package/devel/binutils/Makefile
+++ b/package/devel/binutils/Makefile
@@ -84,7 +84,8 @@ CONFIGURE_ARGS += \
--target=$(REAL_GNU_TARGET_NAME) \
--enable-shared \
--enable-install-libiberty \
- --enable-install-libbfd
+ --enable-install-libbfd \
+ --enable-install-libctf
define Build/Install
$(call Build/Install/Default)
@@ -106,7 +107,7 @@ endef
define Package/libctf/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libctf.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libctf*.so* $(1)/usr/lib/
endef
define Package/libopcodes/install