aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2018-06-28 13:00:10 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2018-09-05 23:49:15 +0200
commit067e2f5f1d0102ffb96d3248e42a29e7352cc29c (patch)
tree07f5bbf0449dd1347a8b8cd5548bbff0f32abbd0 /package/devel
parentecc3165cbc6e2f51a685962cac6074f63097fa05 (diff)
downloadupstream-067e2f5f1d0102ffb96d3248e42a29e7352cc29c.tar.gz
upstream-067e2f5f1d0102ffb96d3248e42a29e7352cc29c.tar.bz2
upstream-067e2f5f1d0102ffb96d3248e42a29e7352cc29c.zip
strace: fix build on aarch64
As of version 4.21, strace enforces mpers by default. The current implementation of aarch64 compat in strace assumes it's identical to ARMv7 EABI and therefore tries to enable m32 personality support. As there is no -m32 support on aarch64, this causes the build to fail. Restore previous strace behavior to fix build on aarch64. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Tested-by: Karl Palsson <karlp@tweak.net.au>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/strace/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/devel/strace/Makefile b/package/devel/strace/Makefile
index 3704aa8b15..ded6d3bb84 100644
--- a/package/devel/strace/Makefile
+++ b/package/devel/strace/Makefile
@@ -30,6 +30,10 @@ include $(INCLUDE_DIR)/package.mk
HOST_CFLAGS += -I$(LINUX_DIR)/user_headers/include
+ifeq ($(ARCH),aarch64)
+ CONFIGURE_ARGS += --enable-mpers=check
+endif
+
CONFIGURE_VARS+= \
LDFLAGS_FOR_BUILD="$(HOST_LDFLAGS)" \
CPPFLAGS_FOR_BUILD="$(HOST_CPPFLAGS)" \