aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel/perf
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-05-22 16:50:47 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-06-05 12:30:05 -0700
commitf50079985c97404d62a208f2937ad6afd3f07f0f (patch)
treed91253b040979858f828a69610aa7cd52bac87ae /package/devel/perf
parent5229c453630c0b023c3d65ef6005adbe48062bbb (diff)
downloadupstream-f50079985c97404d62a208f2937ad6afd3f07f0f.tar.gz
upstream-f50079985c97404d62a208f2937ad6afd3f07f0f.tar.bz2
upstream-f50079985c97404d62a208f2937ad6afd3f07f0f.zip
perf: Depend on KERNEL_PERF_EVENTS
The kernel needs to have PERF_EVENTS built otherwise we will run into the following: root@(none):/# perf top perf_event_open(..., PERF_FLAG_FD_CLOEXEC) failed with unexpected error 89 (Function not implemented) perf_event_open(..., 0) failed unexpectedly with error 89 (Function not implemented) Error: The sys_perf_event_open() syscall returned with 89 (Function not implemented) for event (cycles). /bin/dmesg may provide additional information. No CONFIG_PERF_EVENTS=y kernel support configured? Make sure this functional dependency is captured. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'package/devel/perf')
-rw-r--r--package/devel/perf/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/devel/perf/Makefile b/package/devel/perf/Makefile
index 361e42278c..5bfcaa6994 100644
--- a/package/devel/perf/Makefile
+++ b/package/devel/perf/Makefile
@@ -26,7 +26,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/perf
SECTION:=devel
CATEGORY:=Development
- DEPENDS:= +libelf1 +libdw +libpthread +librt +objdump @!LINUX_3_18 @!IN_SDK @!TARGET_arc770
+ DEPENDS:= +libelf1 +libdw +libpthread +librt +objdump @!LINUX_3_18 @!IN_SDK @!TARGET_arc770 @KERNEL_PERF_EVENTS
TITLE:=Linux performance monitoring tool
VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
URL:=http://www.kernel.org