aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel/perf
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-03-17 08:29:42 +0100
committerMathias Kresin <dev@kresin.me>2017-03-17 08:58:50 +0100
commit66146a223e78b03388ebb308a0e93503b3216384 (patch)
tree774834c599a3fa45eefcfa35bf9814a48bac47a9 /package/devel/perf
parent6a82f4006cb1651bc62e1eb23ca81f1bd19214c0 (diff)
downloadupstream-66146a223e78b03388ebb308a0e93503b3216384.tar.gz
upstream-66146a223e78b03388ebb308a0e93503b3216384.tar.bz2
upstream-66146a223e78b03388ebb308a0e93503b3216384.zip
perf: fix build with kernel 4.9
The musl workaround isn't required anymore and causes build errors with kernel 4.9 when applied. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'package/devel/perf')
-rw-r--r--package/devel/perf/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/devel/perf/Makefile b/package/devel/perf/Makefile
index f2f8d6c95c..a9e11b4e32 100644
--- a/package/devel/perf/Makefile
+++ b/package/devel/perf/Makefile
@@ -61,9 +61,11 @@ MAKE_FLAGS = \
WERROR=0 \
prefix=/usr
+ifdef CONFIG_LINUX_4_4
ifdef CONFIG_USE_MUSL
MAKE_FLAGS += EXTRA_CFLAGS="-I$(CURDIR)/musl-include -include $(CURDIR)/musl-compat.h -D__UCLIBC__"
endif
+endif
define Build/Compile
+$(MAKE_FLAGS) $(MAKE) $(PKG_JOBS) \