aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel/gdb/patches/110-shared_libgcc.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-02-11 17:37:53 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-11 20:34:33 +0100
commit9827c3e9b9d366be2edc8f1d27a1b84d03cfa97d (patch)
treee698fa9d933421bdf27fcd58aa0ac6babdea915b /package/devel/gdb/patches/110-shared_libgcc.patch
parentf4d9d7a26b40db14c5d6a87f19df55dfb9000170 (diff)
downloadupstream-9827c3e9b9d366be2edc8f1d27a1b84d03cfa97d.tar.gz
upstream-9827c3e9b9d366be2edc8f1d27a1b84d03cfa97d.tar.bz2
upstream-9827c3e9b9d366be2edc8f1d27a1b84d03cfa97d.zip
gdb: update to version 7.12.1, fix glibc 2.25 build issues
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/devel/gdb/patches/110-shared_libgcc.patch')
-rw-r--r--package/devel/gdb/patches/110-shared_libgcc.patch76
1 files changed, 76 insertions, 0 deletions
diff --git a/package/devel/gdb/patches/110-shared_libgcc.patch b/package/devel/gdb/patches/110-shared_libgcc.patch
new file mode 100644
index 0000000000..e44616f4a2
--- /dev/null
+++ b/package/devel/gdb/patches/110-shared_libgcc.patch
@@ -0,0 +1,76 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1406,13 +1406,13 @@ if test -z "$LD"; then
+ fi
+ fi
+
+-# Check whether -static-libstdc++ -static-libgcc is supported.
++# Check whether -static-libstdc++ is supported.
+ have_static_libs=no
+ if test "$GCC" = yes; then
+ saved_LDFLAGS="$LDFLAGS"
+
+- LDFLAGS="$LDFLAGS -static-libstdc++ -static-libgcc"
+- AC_MSG_CHECKING([whether g++ accepts -static-libstdc++ -static-libgcc])
++ LDFLAGS="$LDFLAGS -static-libstdc++"
++ AC_MSG_CHECKING([whether g++ accepts -static-libstdc++])
+ AC_LANG_PUSH(C++)
+ AC_LINK_IFELSE([
+ #if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
+@@ -1740,7 +1740,7 @@ AC_ARG_WITH(stage1-ldflags,
+ # if supported. But if the user explicitly specified the libraries to use,
+ # trust that they are doing what they want.
+ if test "$stage1_libs" = "" -a "$have_static_libs" = yes; then
+- stage1_ldflags="-static-libstdc++ -static-libgcc"
++ stage1_ldflags="-static-libstdc++"
+ fi])
+ AC_SUBST(stage1_ldflags)
+
+@@ -1769,7 +1769,7 @@ AC_ARG_WITH(boot-ldflags,
+ # statically. But if the user explicitly specified the libraries to
+ # use, trust that they are doing what they want.
+ if test "$poststage1_libs" = ""; then
+- poststage1_ldflags="-static-libstdc++ -static-libgcc"
++ poststage1_ldflags="-static-libstdc++"
+ fi])
+ AC_SUBST(poststage1_ldflags)
+
+--- a/configure
++++ b/configure
+@@ -5109,14 +5109,14 @@ if test -z "$LD"; then
+ fi
+ fi
+
+-# Check whether -static-libstdc++ -static-libgcc is supported.
++# Check whether -static-libstdc++ is supported.
+ have_static_libs=no
+ if test "$GCC" = yes; then
+ saved_LDFLAGS="$LDFLAGS"
+
+- LDFLAGS="$LDFLAGS -static-libstdc++ -static-libgcc"
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether g++ accepts -static-libstdc++ -static-libgcc" >&5
+-$as_echo_n "checking whether g++ accepts -static-libstdc++ -static-libgcc... " >&6; }
++ LDFLAGS="$LDFLAGS -static-libstdc++"
++ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether g++ accepts -static-libstdc++" >&5
++$as_echo_n "checking whether g++ accepts -static-libstdc++... " >&6; }
+ ac_ext=cpp
+ ac_cpp='$CXXCPP $CPPFLAGS'
+ ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
+@@ -5902,7 +5902,7 @@ else
+ # if supported. But if the user explicitly specified the libraries to use,
+ # trust that they are doing what they want.
+ if test "$stage1_libs" = "" -a "$have_static_libs" = yes; then
+- stage1_ldflags="-static-libstdc++ -static-libgcc"
++ stage1_ldflags="-static-libstdc++"
+ fi
+ fi
+
+@@ -5938,7 +5938,7 @@ else
+ # statically. But if the user explicitly specified the libraries to
+ # use, trust that they are doing what they want.
+ if test "$poststage1_libs" = ""; then
+- poststage1_ldflags="-static-libstdc++ -static-libgcc"
++ poststage1_ldflags="-static-libstdc++"
+ fi
+ fi
+