aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel/binutils
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-08-30 11:02:22 +0000
committerJonas Gorski <jogo@openwrt.org>2014-08-30 11:02:22 +0000
commitc74b5fde310f1776bd49c8c18c15467dc720715b (patch)
tree434b263bfd9fb0e11de84a97707f707a651aa217 /package/devel/binutils
parentf11bd56f31422f4c7508999cfe9faa27a850e67c (diff)
downloadupstream-c74b5fde310f1776bd49c8c18c15467dc720715b.tar.gz
upstream-c74b5fde310f1776bd49c8c18c15467dc720715b.tar.bz2
upstream-c74b5fde310f1776bd49c8c18c15467dc720715b.zip
binutils: link libbfd and libopcodes dynamically again
Build libbfd and libopcodes as shared libraries, else they get linked statically into every binary, increasing each binary size by ~650kB. Reduces binutils package size to old expected values. Fixes #17060. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 42337
Diffstat (limited to 'package/devel/binutils')
-rw-r--r--package/devel/binutils/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/devel/binutils/Makefile b/package/devel/binutils/Makefile
index a88b5d1724..e8d45d2d8b 100644
--- a/package/devel/binutils/Makefile
+++ b/package/devel/binutils/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=binutils
PKG_VERSION:=2.24
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=@GNU/binutils
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -48,6 +48,7 @@ endef
TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
+ --enable-shared \
--enable-install-libiberty \
--enable-install-libbfd
@@ -67,6 +68,8 @@ endef
define Package/objdump/install
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/bin/objdump $(1)/usr/bin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libopcodes*.so $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libbfd*.so $(1)/usr/lib/
endef
define Package/binutils/install