aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel/binutils
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-10-10 13:26:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-10-10 13:26:27 +0000
commitc6b27e2885ab53a2de14e21044e9749082079fa2 (patch)
treee6c6a5ba072ebfbbecaeeffb52b305bf9e4bd216 /package/devel/binutils
parent936c1b9424ec53f450a3b62ac2d8a9155d45ae88 (diff)
downloadupstream-c6b27e2885ab53a2de14e21044e9749082079fa2.tar.gz
upstream-c6b27e2885ab53a2de14e21044e9749082079fa2.tar.bz2
upstream-c6b27e2885ab53a2de14e21044e9749082079fa2.zip
move a few development packages to trunk and add myself as a maintainer
SVN-Revision: 33705
Diffstat (limited to 'package/devel/binutils')
-rw-r--r--package/devel/binutils/Makefile115
1 files changed, 115 insertions, 0 deletions
diff --git a/package/devel/binutils/Makefile b/package/devel/binutils/Makefile
new file mode 100644
index 0000000000..09710d4b9e
--- /dev/null
+++ b/package/devel/binutils/Makefile
@@ -0,0 +1,115 @@
+#
+# Copyright (C) 2006-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=binutils
+PKG_VERSION:=$(strip $(subst ",, $(CONFIG_BINUTILS_VERSION)))
+#"))
+PKG_RELEASE:=5
+
+PKG_SOURCE_URL:=@GNU/binutils
+PKG_SOURCE:=binutils-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=
+
+PATCH_DIR:=$(TOPDIR)/toolchain/binutils/patches/$(PKG_VERSION)
+
+PKG_FIXUP:=autoreconf
+PKG_LIBTOOL_PATHS:=. gas bfd opcodes gprof binutils ld libiberty gold intl
+PKG_REMOVE_FILES:=libtool.m4
+PKG_INSTALL:=1
+
+PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/binutils
+ SECTION:=devel
+ CATEGORY:=Development
+ TITLE:=binutils
+ DEPENDS:=+objdump
+endef
+
+define Package/objdump
+ SECTION:=devel
+ CATEGORY:=Development
+ TITLE:=objdump
+ DEPENDS:=+zlib
+endef
+
+define Package/binutils/description
+ The Binutils package contains a linker, an assembler, and other tools for handling object files
+endef
+
+CONFIGURE_ARGS = \
+ --target=$(REAL_GNU_TARGET_NAME) \
+ --host=$(REAL_GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --disable-multilib \
+ --disable-werror \
+ --disable-nls \
+ --enable-shared \
+ $(SOFT_FLOAT_CONFIG_OPTION) \
+ $(call qstrip,$(CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS))
+
+TARGET_CFLAGS += $(FPIC)
+TARGET_LDFLAGS := -L$(PKG_BUILD_DIR)/libiberty $(TARGET_LDFLAGS)
+
+define Build/Configure
+ $(call Build/Configure/Default)
+ $(call Build/Compile/Default, \
+ configure-bfd \
+ configure-binutils \
+ configure-etc \
+ configure-gas \
+ configure-gprof \
+ configure-intl \
+ configure-ld \
+ configure-libiberty \
+ configure-opcodes \
+ )
+ $(MAKE) CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR)/bfd/po Makefile
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/{lib,include}
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/* \
+ $(1)/usr/lib/
+ $(CP) \
+ $(PKG_BUILD_DIR)/include/*.h \
+ $(1)/usr/include/
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/include/* \
+ $(1)/usr/include/
+ rm -f $(1)/usr/include/gdbm.h
+endef
+
+define Build/Compile
+ +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR)/bfd/doc/ CFLAGS="-I$(PKG_BUILD_DIR)/include" chew
+ $(call Build/Compile/Default)
+endef
+
+define Package/objdump/install
+ $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/objdump $(1)/usr/bin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libopcodes*.so $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libbfd*.so $(1)/usr/lib/
+endef
+
+define Package/binutils/install
+ $(INSTALL_DIR) $(1)/usr $(1)/bin
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/ $(1)/usr/
+ mv $(1)/usr/bin/strings $(1)/bin/strings
+ rm -f $(1)/usr/bin/objdump
+endef
+
+$(eval $(call BuildPackage,binutils))
+$(eval $(call BuildPackage,objdump))