aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-06-10 13:19:45 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-06-10 13:19:45 +0000
commite2be7290b1cd0e6061d7d0f982ac5da13ff1a685 (patch)
tree1898b04b8a5a26b62411338623c3f87f3f1b8019 /package/busybox
parentfd29691f895a2616148501cb288f2b9ef10ca9a8 (diff)
downloadupstream-e2be7290b1cd0e6061d7d0f982ac5da13ff1a685.tar.gz
upstream-e2be7290b1cd0e6061d7d0f982ac5da13ff1a685.tar.bz2
upstream-e2be7290b1cd0e6061d7d0f982ac5da13ff1a685.zip
busybox: fix bad variable substitution on right hand side of I/O redirection, imported patch from upstream bug 5282
SVN-Revision: 32162
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/Makefile2
-rw-r--r--package/busybox/patches/251-ash_fix-redir-substitution.patch12
2 files changed, 13 insertions, 1 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index af27df071b..1d2d7b4fac 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.19.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_FLAGS:=essential
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/package/busybox/patches/251-ash_fix-redir-substitution.patch b/package/busybox/patches/251-ash_fix-redir-substitution.patch
new file mode 100644
index 0000000000..cb2ae94e04
--- /dev/null
+++ b/package/busybox/patches/251-ash_fix-redir-substitution.patch
@@ -0,0 +1,12 @@
+--- a/shell/ash.c
++++ b/shell/ash.c
+@@ -6846,8 +6846,7 @@ evalvar(char *p, int flags, struct strli
+ patloc = expdest - (char *)stackblock();
+ if (NULL == subevalvar(p, /* varname: */ NULL, patloc, subtype,
+ startloc, varflags,
+-//TODO: | EXP_REDIR too? All other such places do it too
+- /* quotes: */ flags & (EXP_FULL | EXP_CASE),
++ /* quotes: */ flags & (EXP_FULL | EXP_CASE | EXP_REDIR),
+ var_str_list)
+ ) {
+ int amount = expdest - (