aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-11-11 03:02:26 +0000
committerNicolas Thill <nico@openwrt.org>2008-11-11 03:02:26 +0000
commit3691a072ccab9fb2eeb5a0d722d9fe0c4eecaf36 (patch)
tree0cf2bc5314986224874990c4aed880f164a3e095 /package/busybox
parentd186cdbfd092d62bc6137b53e7a2cfeeb4afb951 (diff)
downloadupstream-3691a072ccab9fb2eeb5a0d722d9fe0c4eecaf36.tar.gz
upstream-3691a072ccab9fb2eeb5a0d722d9fe0c4eecaf36.tar.bz2
upstream-3691a072ccab9fb2eeb5a0d722d9fe0c4eecaf36.zip
bridge (brctl) changes: - enable brctl in busybox - disable bridge-utils - bumb busybox release number
SVN-Revision: 13180
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/Makefile4
-rw-r--r--package/busybox/config/networking/Config.in6
2 files changed, 5 insertions, 5 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 2f97794261..3ac2898730 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.11.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.busybox.net/downloads \
diff --git a/package/busybox/config/networking/Config.in b/package/busybox/config/networking/Config.in
index 3da608d9b4..e81a2efcef 100644
--- a/package/busybox/config/networking/Config.in
+++ b/package/busybox/config/networking/Config.in
@@ -49,14 +49,14 @@ config BUSYBOX_CONFIG_ARPING
config BUSYBOX_CONFIG_BRCTL
bool "brctl"
- default n
+ default y
help
Manage ethernet bridges.
Supports addbr/delbr and addif/delif.
config BUSYBOX_CONFIG_FEATURE_BRCTL_FANCY
bool "Fancy options"
- default n
+ default y
depends on BUSYBOX_CONFIG_BRCTL
help
Add support for extended option like:
@@ -67,7 +67,7 @@ config BUSYBOX_CONFIG_FEATURE_BRCTL_FANCY
config BUSYBOX_CONFIG_FEATURE_BRCTL_SHOW
bool "Support show, showmac and showstp"
- default n
+ default y
depends on BUSYBOX_CONFIG_BRCTL && BUSYBOX_CONFIG_FEATURE_BRCTL_FANCY
help
Add support for option which prints the current config: