aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-11 18:17:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-11 18:17:08 +0000
commitaeed501f9c28ac3c3b21b3670cbac395f057097f (patch)
treeb318a8e384a123e5852ddef80f8daa0e7592d3f1 /package/busybox/Makefile
parentd0110247132d2f6f4bfa0a0c2e77de74aebe977f (diff)
downloadupstream-aeed501f9c28ac3c3b21b3670cbac395f057097f.tar.gz
upstream-aeed501f9c28ac3c3b21b3670cbac395f057097f.tar.bz2
upstream-aeed501f9c28ac3c3b21b3670cbac395f057097f.zip
replace libcgi with some code extracted from haserl - libcgi is too inflexible and breaks rrdtool
SVN-Revision: 6554
Diffstat (limited to 'package/busybox/Makefile')
-rw-r--r--package/busybox/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index eae037aaaa..cf6ddac6ec 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -19,7 +19,7 @@ PKG_MD5SUM:=5728403bce309cdabcffa414e2e64052
PKG_CAT:=bzcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_BUILD_DEPENDS:=libcgi
+PKG_BUILD_DEPENDS:=gcgi
include $(INCLUDE_DIR)/package.mk
@@ -62,10 +62,9 @@ define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
- EXTRA_CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+ EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
ARCH="$(ARCH)" \
IPKG_ARCH="$(ARCH)" \
- EXTRA_LIBS="$(STAGING_DIR)/usr/lib/libcgi.a" \
all
endef
@@ -73,11 +72,10 @@ define Package/busybox/install
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
- EXTRA_CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+ EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
ARCH="$(ARCH)" \
IPKG_ARCH="$(ARCH)" \
CONFIG_PREFIX="$(1)" \
- EXTRA_LIBS="$(STAGING_DIR)/usr/lib/libcgi.a" \
install
$(INSTALL_DIR) $(1)/etc/init.d
for tmp in $(init-y); do \