aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 15:30:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 15:30:50 +0000
commit77acae652fa5607fc76b07ce3ce558e8a845de30 (patch)
tree6156097aa76c3eb354e5af3e97c1857f2acf998a /package/busybox/Makefile
parent443d4b872619902bb2457c5e2dbdb9e9786a9b14 (diff)
downloadupstream-77acae652fa5607fc76b07ce3ce558e8a845de30.tar.gz
upstream-77acae652fa5607fc76b07ce3ce558e8a845de30.tar.bz2
upstream-77acae652fa5607fc76b07ce3ce558e8a845de30.zip
add support for a common shell include file, which is evaluated for every make shell call, simplify variable passing to the shell with shvar and shexport templates, use Package/<pkgname>/config for adding config.in data
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@5014 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox/Makefile')
-rw-r--r--package/busybox/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index c87701ad1e..f56d2462d7 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -31,10 +31,12 @@ define Package/busybox
It slices, it dices, it makes Julian Fries.
URL:=http://busybox.net/
MENU:=1
- CONFIG:=\\\
- menu "Configuration" \\\
- depends on PACKAGE_busybox \\\
- source "$(SOURCE)/config/Config.in" \\\
+endef
+
+define Package/busybox/config
+ menu "Configuration"
+ depends on PACKAGE_busybox
+ source "$(SOURCE)/config/Config.in"
endmenu
endef