aboutsummaryrefslogtreecommitdiffstats
path: root/package/broadcom-wl
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-08-05 22:32:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-08-05 22:32:26 +0000
commit0cc7199e713dc0be78509256bad1b5674c895b74 (patch)
treed2b85d02186865d34628482d98009887afa7cfb9 /package/broadcom-wl
parente0b43982fbd6430984dd9ee18688af5c4a7a1d4c (diff)
downloadupstream-0cc7199e713dc0be78509256bad1b5674c895b74.tar.gz
upstream-0cc7199e713dc0be78509256bad1b5674c895b74.tar.bz2
upstream-0cc7199e713dc0be78509256bad1b5674c895b74.zip
install libshared into the staging dir (required by wrt-radauth)
SVN-Revision: 12181
Diffstat (limited to 'package/broadcom-wl')
-rw-r--r--package/broadcom-wl/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/broadcom-wl/Makefile b/package/broadcom-wl/Makefile
index 04f2960c20..5db45cdba0 100644
--- a/package/broadcom-wl/Makefile
+++ b/package/broadcom-wl/Makefile
@@ -165,6 +165,11 @@ define Build/Compile
$(TARGET_CC) -o $(PKG_BUILD_DIR)/wl $(PKG_BUILD_DIR)/wl_exe.o
endef
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/router/shared/libshared.a $(1)/usr/lib/
+endef
+
define Package/wlc/install
$(CP) ./files/* $(1)/
$(INSTALL_DIR) $(1)/sbin