aboutsummaryrefslogtreecommitdiffstats
path: root/package/broadcom-wl/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-27 10:09:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-27 10:09:53 +0000
commitb420fccd92ffb8efe257451d385e2db8babb61d2 (patch)
tree0754b007d27657e168580bacc49de5c4df89c92a /package/broadcom-wl/Makefile
parent87c22c5f139ff8c33345d3c8e6e3cef2028e1e82 (diff)
downloadupstream-b420fccd92ffb8efe257451d385e2db8babb61d2.tar.gz
upstream-b420fccd92ffb8efe257451d385e2db8babb61d2.tar.bz2
upstream-b420fccd92ffb8efe257451d385e2db8babb61d2.zip
add broadcom-wl patchtable again
SVN-Revision: 6215
Diffstat (limited to 'package/broadcom-wl/Makefile')
-rw-r--r--package/broadcom-wl/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/broadcom-wl/Makefile b/package/broadcom-wl/Makefile
index fd6671b289..132b69ca2d 100644
--- a/package/broadcom-wl/Makefile
+++ b/package/broadcom-wl/Makefile
@@ -81,6 +81,20 @@ define Package/nas
proprietary Broadcom wl driver.
endef
+
+define install_template
+ $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/kmod/wl$(2).o.patch $(1)/lib/modules/$(LINUX_VERSION)/
+endef
+
+define KernelPackage/brcm-wl/install
+ $(call install_template,$(1),)
+endef
+
+define KernelPackage/brcm-wl_mimo/install
+ $(call install_template,$(1),_mimo)
+endef
+
MAKEFLAGS_KMOD:= -C "$(LINUX_DIR)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
ARCH="$(LINUX_KARCH)" \