aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-02-10 01:05:00 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-02-10 01:20:58 +0000
commitffa0ae17f7c8010628a622b875b67ee1a9f3dec2 (patch)
tree494a4aa290c0f4bf2284628bd6ff007bd67549dc /package/boot
parent1f559cafe5cc1193a5962d40a2d938c66c783171 (diff)
downloadupstream-ffa0ae17f7c8010628a622b875b67ee1a9f3dec2.tar.gz
upstream-ffa0ae17f7c8010628a622b875b67ee1a9f3dec2.tar.bz2
upstream-ffa0ae17f7c8010628a622b875b67ee1a9f3dec2.zip
arm-trusted-firmware-tools: fix passing of CFLAGS
HOST_CFLAGS were ignored as they were passed on incorrectly which lead to build failure if OpenSSL wasn't present on the build host. Fix that by properly passing HOST_CFLAGS when building each tool. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/arm-trusted-firmware-tools/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/boot/arm-trusted-firmware-tools/Makefile b/package/boot/arm-trusted-firmware-tools/Makefile
index 189817f00a..a7112724c0 100644
--- a/package/boot/arm-trusted-firmware-tools/Makefile
+++ b/package/boot/arm-trusted-firmware-tools/Makefile
@@ -29,15 +29,14 @@ define Package/arm-trusted-firmware-tools
BUILDONLY:=1
endef
-HOST_CFLAGS += -Wall -Werror -pedantic -std=c99
define Host/Compile
$(MAKE) -C \
$(HOST_BUILD_DIR)/tools/fiptool \
- CFLAGS="$(HOST_CFLAGS)" \
+ CPPFLAGS="$(HOST_CFLAGS)" \
LDFLAGS="$(HOST_LDFLAGS)"
$(MAKE) -C \
$(HOST_BUILD_DIR)/tools/sptool \
- CFLAGS="$(HOST_CFLAGS)" \
+ CPPFLAGS="$(HOST_CFLAGS)" \
LDFLAGS="$(HOST_LDFLAGS)"
endef