aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
author李国 <uxgood.org@gmail.com>2020-07-25 05:14:52 +0000
committerPaul Spooren <mail@aparcar.org>2021-06-20 13:34:27 -1000
commite4723755f237a0e5fab132ab870d00ea82e7fb82 (patch)
tree73893b586d00d6e334c36ab551df6efda3378483 /package/boot
parentca941041366602d4da0bf2c04bb0d3c25ed4fa21 (diff)
downloadupstream-e4723755f237a0e5fab132ab870d00ea82e7fb82.tar.gz
upstream-e4723755f237a0e5fab132ab870d00ea82e7fb82.tar.bz2
upstream-e4723755f237a0e5fab132ab870d00ea82e7fb82.zip
grub2: pass compilation parameters more accurately
In order for the grub2 boot-related code to compile normally, we have made many adjustments to the compilation parameters. These adjustments are not necessary for tools-related code. We apply these parameter adjustments only to the boot-related code. Signed-off-by: 李国 <uxgood.org@gmail.com>
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/grub2/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/package/boot/grub2/Makefile b/package/boot/grub2/Makefile
index 0610d96e90..3cdb608cbf 100644
--- a/package/boot/grub2/Makefile
+++ b/package/boot/grub2/Makefile
@@ -17,8 +17,10 @@ PKG_HASH:=2c87f1f21e2ab50043e6cd9163c08f1b6c3a6171556bf23ff9ed65b074145484
HOST_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=grub2/host
-PKG_ASLR_PIE:=0
-PKG_SSP:=0
+ifneq ($(BUILD_VARIANT),none)
+ PKG_ASLR_PIE:=0
+ PKG_SSP:=0
+endif
PKG_FLAGS:=nonshared
@@ -96,9 +98,9 @@ HOST_MAKE_FLAGS += \
TARGET_RANLIB=$(TARGET_RANLIB) \
LIBLZMA=$(STAGING_DIR_HOST)/lib/liblzma.a
-TARGET_CFLAGS := $(filter-out -O2 -O3 -fno-plt,$(TARGET_CFLAGS))
ifneq ($(BUILD_VARIANT),none)
+ TARGET_CFLAGS := $(filter-out -O2 -O3 -fno-plt,$(TARGET_CFLAGS))
MAKE_PATH := grub-core
endif