aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2020-04-29 11:02:27 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2021-04-11 23:14:52 +0200
commitc75d441f20947e63f8026558d474e6752f6f1dcc (patch)
tree69033066080801ce90e7edc2641c8a38a859d5fd /package/boot
parentacb0788b8e586cdd1329ff16d4570879e7f48f7b (diff)
downloadupstream-c75d441f20947e63f8026558d474e6752f6f1dcc.tar.gz
upstream-c75d441f20947e63f8026558d474e6752f6f1dcc.tar.bz2
upstream-c75d441f20947e63f8026558d474e6752f6f1dcc.zip
uboot-sunxi: add ATF variable for specifying which flavour to use
In preparation for H6 support (which requires a separate ATF blob), add an envvar to the A64 boards specifying which ATF blob to use. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/arm-trusted-firmware-sunxi/Makefile2
-rw-r--r--package/boot/uboot-sunxi/Makefile11
2 files changed, 11 insertions, 2 deletions
diff --git a/package/boot/arm-trusted-firmware-sunxi/Makefile b/package/boot/arm-trusted-firmware-sunxi/Makefile
index 0211e5e030..ed2390a36c 100644
--- a/package/boot/arm-trusted-firmware-sunxi/Makefile
+++ b/package/boot/arm-trusted-firmware-sunxi/Makefile
@@ -42,7 +42,7 @@ MAKE_FLAGS += \
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
- $(CP) $(PKG_BUILD_DIR)/build/sun50i_a64/release/bl31.bin $(STAGING_DIR_IMAGE)/bl31.bin
+ $(CP) $(PKG_BUILD_DIR)/build/sun50i_a64/release/bl31.bin $(STAGING_DIR_IMAGE)/bl31_a64.bin
endef
define Package/arm-trusted-firmware-sunxi/install
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 38147339a4..19c158e230 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -31,6 +31,7 @@ define U-Boot/a64-olinuxino
BUILD_DEVICES:=olimex_a64-olinuxino
DEPENDS:=+PACKAGE_u-boot-olimex_a64-olinuxino:arm-trusted-firmware-sunxi
UENV:=a64
+ ATF:=a64
endef
define U-Boot/a64-olinuxino-emmc
@@ -39,6 +40,7 @@ define U-Boot/a64-olinuxino-emmc
BUILD_DEVICES:=olimex_a64-olinuxino-emmc
DEPENDS:=+PACKAGE_u-boot-olimex_a64-olinuxino-emmc:arm-trusted-firmware-sunxi
UENV:=a64
+ ATF:=a64
endef
define U-Boot/A10-OLinuXino-Lime
@@ -238,6 +240,7 @@ define U-Boot/libretech_all_h3_cc_h5
BUILD_DEVICES:=libretech_all-h3-cc-h5
DEPENDS:=+PACKAGE_u-boot-libretech_all_h3_cc_h5:arm-trusted-firmware-sunxi
UENV:=a64
+ ATF:=a64
endef
define U-Boot/nanopi_neo_plus2
@@ -246,6 +249,7 @@ define U-Boot/nanopi_neo_plus2
BUILD_DEVICES:=friendlyarm_nanopi-neo-plus2
DEPENDS:=+PACKAGE_u-boot-nanopi_neo_plus2:arm-trusted-firmware-sunxi
UENV:=a64
+ ATF:=a64
endef
define U-Boot/nanopi_neo2
@@ -254,6 +258,7 @@ define U-Boot/nanopi_neo2
BUILD_DEVICES:=friendlyarm_nanopi-neo2
DEPENDS:=+PACKAGE_u-boot-nanopi_neo2:arm-trusted-firmware-sunxi
UENV:=a64
+ ATF:=a64
endef
define U-Boot/pine64_plus
@@ -262,6 +267,7 @@ define U-Boot/pine64_plus
BUILD_DEVICES:=pine64_pine64-plus
DEPENDS:=+PACKAGE_u-boot-pine64_plus:arm-trusted-firmware-sunxi
UENV:=a64
+ ATF:=a64
endef
define U-Boot/bananapi_m2_plus_h3
@@ -276,6 +282,7 @@ define U-Boot/sopine_baseboard
BUILD_DEVICES:=pine64_sopine-baseboard
DEPENDS:=+PACKAGE_u-boot-sopine_baseboard:arm-trusted-firmware-sunxi
UENV:=a64
+ ATF:=a64
endef
@@ -285,6 +292,7 @@ define U-Boot/orangepi_zero_plus
BUILD_DEVICES:=xunlong_orangepi-zero-plus
DEPENDS:=+PACKAGE_u-boot-orangepi_zero_plus:arm-trusted-firmware-sunxi
UENV:=a64
+ ATF:=a64
endef
define U-Boot/orangepi_pc2
@@ -293,6 +301,7 @@ define U-Boot/orangepi_pc2
BUILD_DEVICES:=xunlong_orangepi-pc2
DEPENDS:=+PACKAGE_u-boot-orangepi_pc2:arm-trusted-firmware-sunxi
UENV:=a64
+ ATF:=a64
endef
define U-Boot/Bananapi_M2_Ultra
@@ -349,7 +358,7 @@ UBOOT_TARGETS := \
UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes
UBOOT_MAKE_FLAGS += \
- BL31=$(STAGING_DIR_IMAGE)/bl31.bin
+ BL31=$(STAGING_DIR_IMAGE)/bl31_$(ATF).bin
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)