aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-01-23 22:25:39 +0100
committerMathias Kresin <dev@kresin.me>2019-01-26 21:46:32 +0100
commitc2bdd018a301662258ec745bf4da71d6d6193af1 (patch)
treeefb4e7696df8ecffad5e6e50f1c2dc0c40dbd110 /package/boot
parent66a4978b4355e3e8f860a87ca14c0f293931d038 (diff)
downloadupstream-c2bdd018a301662258ec745bf4da71d6d6193af1.tar.gz
upstream-c2bdd018a301662258ec745bf4da71d6d6193af1.tar.bz2
upstream-c2bdd018a301662258ec745bf4da71d6d6193af1.zip
uboot-imx6: Bump to 2019.01
Build tested: apalis, mx6sabresd, nitrogen6dl, nitrogen6dl2g, nitrogen6q, nitrogen6q2g, nitrogen6s, nitrogen6s1g, wandboard Run tested: apalis (pending PR #1595) Cc: Felix Fietkau <nbd@nbd.name> Cc: Vladimir Vid <vladimir.vid@sartura.hr> Cc: Koen Vandeputte <koen.vandeputte@ncentric.com> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/uboot-imx6/Makefile4
-rw-r--r--package/boot/uboot-imx6/patches/100-wandboard-enable-fit.patch6
-rw-r--r--package/boot/uboot-imx6/patches/110-mx6cuboxi-mmc-fallback.patch10
3 files changed, 10 insertions, 10 deletions
diff --git a/package/boot/uboot-imx6/Makefile b/package/boot/uboot-imx6/Makefile
index 3eba249bf3..25d68bf6ca 100644
--- a/package/boot/uboot-imx6/Makefile
+++ b/package/boot/uboot-imx6/Makefile
@@ -7,10 +7,10 @@
include $(TOPDIR)/rules.mk
-PKG_VERSION:=2018.03
+PKG_VERSION:=2019.01
PKG_RELEASE:=1
-PKG_HASH:=7e7477534409d5368eb1371ffde6820f0f79780a1a1f676161c48442cb303dfd
+PKG_HASH:=50bd7e5a466ab828914d080d5f6a432345b500e8fba1ad3b7b61e95e60d51c22
include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
diff --git a/package/boot/uboot-imx6/patches/100-wandboard-enable-fit.patch b/package/boot/uboot-imx6/patches/100-wandboard-enable-fit.patch
index 6bfcc1ff71..3ab61528f7 100644
--- a/package/boot/uboot-imx6/patches/100-wandboard-enable-fit.patch
+++ b/package/boot/uboot-imx6/patches/100-wandboard-enable-fit.patch
@@ -1,6 +1,6 @@
--- a/configs/wandboard_defconfig
+++ b/configs/wandboard_defconfig
-@@ -27,7 +27,7 @@ CONFIG_CMD_I2C=y
+@@ -29,7 +29,7 @@ CONFIG_CMD_I2C=y
CONFIG_CMD_MMC=y
CONFIG_CMD_SATA=y
CONFIG_CMD_USB=y
@@ -8,8 +8,8 @@
+# CONFIG_CMD_CACHE is not set
CONFIG_CMD_EXT4_WRITE=y
CONFIG_ENV_IS_IN_MMC=y
- CONFIG_DM=y
-@@ -39,3 +39,5 @@ CONFIG_USB_STORAGE=y
+ CONFIG_ENV_VARS_UBOOT_RUNTIME_CONFIG=y
+@@ -43,3 +43,5 @@ CONFIG_USB=y
CONFIG_VIDEO=y
# CONFIG_VIDEO_SW_CURSOR is not set
CONFIG_OF_LIBFDT=y
diff --git a/package/boot/uboot-imx6/patches/110-mx6cuboxi-mmc-fallback.patch b/package/boot/uboot-imx6/patches/110-mx6cuboxi-mmc-fallback.patch
index 0883eb7b28..4b34a831ba 100644
--- a/package/boot/uboot-imx6/patches/110-mx6cuboxi-mmc-fallback.patch
+++ b/package/boot/uboot-imx6/patches/110-mx6cuboxi-mmc-fallback.patch
@@ -1,7 +1,7 @@
--- a/board/solidrun/mx6cuboxi/mx6cuboxi.c
+++ b/board/solidrun/mx6cuboxi/mx6cuboxi.c
-@@ -334,6 +334,12 @@ int board_init(void)
- return ret;
+@@ -290,6 +290,12 @@ static void setup_iomux_enet(void)
+ udelay(100);
}
+void board_boot_order(u32 *spl_boot_list)
@@ -10,12 +10,12 @@
+ spl_boot_list[1] = BOOT_DEVICE_MMC1;
+}
+
- static bool is_hummingboard(void)
+ int board_phy_config(struct phy_device *phydev)
{
- int val1, val2;
+ if (phydev->drv->config)
--- a/arch/arm/mach-imx/spl.c
+++ b/arch/arm/mach-imx/spl.c
-@@ -136,7 +136,7 @@ int g_dnl_bind_fixup(struct usb_device_d
+@@ -167,7 +167,7 @@ int g_dnl_bind_fixup(struct usb_device_d
/* called from spl_mmc to see type of boot mode for storage (RAW or FAT) */
u32 spl_boot_mode(const u32 boot_device)
{