aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2021-01-18 09:00:42 +0100
committerZoltan HERPAI <wigyori@uid0.hu>2021-04-12 14:02:02 +0200
commit9aa66b8ce730aebff76d353392151708a897a3a0 (patch)
treeccd0a1acdf9d156b3c3430ecd0b710cea77d7e50 /package/boot
parent172fa3bc7544ce940ce724d682d66109a3e14a11 (diff)
downloadupstream-9aa66b8ce730aebff76d353392151708a897a3a0.tar.gz
upstream-9aa66b8ce730aebff76d353392151708a897a3a0.tar.bz2
upstream-9aa66b8ce730aebff76d353392151708a897a3a0.zip
sunxi: add support for Banana Pi M2 Berry
CPU: Allwinner V40 quad-core Cortex A7 @ 1.2GHz Memory: 1GB DDR3 Storage: SDcard, native SATA Network: 10/100/1000M ethernet, Ampak AP6212 wifi + BT USB: 4x USB 2.0 Installation: Use the standard sunxi installation to an SD-card. While the board is very similar to the M2 Ultra board (the V40 is the automotive version of the R40), as both the u-boot and kernel supports them separately, and some pins are different, let's add a separate device spec. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/uboot-sunxi/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 17f1c0d158..66ca07fa12 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -319,6 +319,12 @@ define U-Boot/Bananapi_M2_Ultra
BUILD_DEVICES:=sinovoip_bananapi-m2-ultra
endef
+define U-Boot/bananapi_m2_berry
+ BUILD_SUBTARGET:=cortexa7
+ NAME:=Bananapi M2 Berry
+ BUILD_DEVICES:=sinovoip_bananapi-m2-berry
+endef
+
UBOOT_TARGETS := \
a64-olinuxino \
a64-olinuxino-emmc \
@@ -330,6 +336,7 @@ UBOOT_TARGETS := \
A20-OLinuXino_MICRO \
bananapi_m2_plus_h3 \
Bananapi \
+ bananapi_m2_berry \
Bananapi_M2_Ultra \
Bananapro \
Cubieboard \