aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2021-04-02 00:52:56 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2021-05-20 13:57:43 +0200
commit6f3a05ebb07570a15d0f8d3d7532272e71786781 (patch)
tree1172fd3e21420d6344d652a963a69c48694e60fc /package/boot
parent9a9990300547272338d265cfb9fed0c4d923fa8a (diff)
downloadupstream-6f3a05ebb07570a15d0f8d3d7532272e71786781.tar.gz
upstream-6f3a05ebb07570a15d0f8d3d7532272e71786781.tar.bz2
upstream-6f3a05ebb07570a15d0f8d3d7532272e71786781.zip
uboot-envtools: support uci-default config also per subtargets
The current version of 'uboot-envtools' package generates dedicated uci-default file only per target. This change makes it possible to use subtarget-specific files, with name pattern: 'target_subtarget' (example: 'ath79_nand'). The subtarget-specific files will take precedence over target-specific one. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/uboot-envtools/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index 02bca9cea3..1ace390c40 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -73,9 +73,13 @@ define Package/uboot-envtools/install
$(INSTALL_DIR) $(1)/lib
$(INSTALL_DATA) ./files/uboot-envtools.sh $(1)/lib
$(INSTALL_DIR) $(1)/etc/uci-defaults
- $(if $(wildcard ./files/$(BOARD)), \
- $(INSTALL_DATA) ./files/$(BOARD) \
- $(1)/etc/uci-defaults/30_uboot-envtools \
+ $(if $(wildcard ./files/$(BOARD)_$(SUBTARGET)), \
+ $(INSTALL_DATA) ./files/$(BOARD)_$(SUBTARGET) \
+ $(1)/etc/uci-defaults/30_uboot-envtools, \
+ $(if $(wildcard ./files/$(BOARD)), \
+ $(INSTALL_DATA) ./files/$(BOARD) \
+ $(1)/etc/uci-defaults/30_uboot-envtools \
+ ) \
)
endef