aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2021-01-17 08:38:53 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2021-01-30 14:46:32 +0100
commit5fae94d987f2261b148c035130a00350c905a13e (patch)
tree1ebf100508f1d64af4c2f6e3385455c0dd3bc794 /package/boot
parent8f3bd881c92894654bcc63d5c4704dd6e6fbcc03 (diff)
downloadupstream-5fae94d987f2261b148c035130a00350c905a13e.tar.gz
upstream-5fae94d987f2261b148c035130a00350c905a13e.tar.bz2
upstream-5fae94d987f2261b148c035130a00350c905a13e.zip
arm-trusted-firmware-mvebu: bump espressobin boards to CPU_1000_DDR_800
The cpufreq issue has been identified and a fix is in the process of beeing upstreamed [0]. Bump the boards to the default 1000MHz so they can run at that frequency once the fix is merged. Until then the boards are stuck at 800MHz (just claiming to run 1000Hz, which is a lie). [0] https://lore.kernel.org/linux-arm-kernel/20210114124032.12765-1-pali@kernel.org/ Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/arm-trusted-firmware-mvebu/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/boot/arm-trusted-firmware-mvebu/Makefile b/package/boot/arm-trusted-firmware-mvebu/Makefile
index 55600260bf..a72fd53c75 100644
--- a/package/boot/arm-trusted-firmware-mvebu/Makefile
+++ b/package/boot/arm-trusted-firmware-mvebu/Makefile
@@ -32,7 +32,7 @@ define Trusted-Firmware-A/espressobin-512mb
BUILD_DEVICES:=globalscale_espressobin
UBOOT:=espressobin
DDR_TOPOLOGY:=0
- CLOCKSPRESET:=CPU_800_DDR_800
+ CLOCKSPRESET:=CPU_1000_DDR_800
PLAT:=a3700
endef
@@ -42,7 +42,7 @@ define Trusted-Firmware-A/espressobin-v3-v5-1gb-1cs
BUILD_DEVICES:=globalscale_espressobin
UBOOT:=espressobin
DDR_TOPOLOGY:=4
- CLOCKSPRESET:=CPU_800_DDR_800
+ CLOCKSPRESET:=CPU_1000_DDR_800
PLAT:=a3700
endef
@@ -52,7 +52,7 @@ define Trusted-Firmware-A/espressobin-v3-v5-1gb-2cs
BUILD_DEVICES:=globalscale_espressobin
UBOOT:=espressobin
DDR_TOPOLOGY:=2
- CLOCKSPRESET:=CPU_800_DDR_800
+ CLOCKSPRESET:=CPU_1000_DDR_800
PLAT:=a3700
endef
@@ -62,7 +62,7 @@ define Trusted-Firmware-A/espressobin-v3-v5-2gb
BUILD_DEVICES:=globalscale_espressobin
UBOOT:=espressobin
DDR_TOPOLOGY:=7
- CLOCKSPRESET:=CPU_800_DDR_800
+ CLOCKSPRESET:=CPU_1000_DDR_800
PLAT:=a3700
endef
@@ -72,7 +72,7 @@ define Trusted-Firmware-A/espressobin-v7-1gb
BUILD_DEVICES:=globalscale_espressobin-v7
UBOOT:=espressobin
DDR_TOPOLOGY:=5
- CLOCKSPRESET:=CPU_800_DDR_800
+ CLOCKSPRESET:=CPU_1000_DDR_800
PLAT:=a3700
endef
@@ -82,7 +82,7 @@ define Trusted-Firmware-A/espressobin-v7-2gb
BUILD_DEVICES:=globalscale_espressobin-v7
UBOOT:=espressobin
DDR_TOPOLOGY:=6
- CLOCKSPRESET:=CPU_800_DDR_800
+ CLOCKSPRESET:=CPU_1000_DDR_800
PLAT:=a3700
endef