aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2021-01-17 08:38:22 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2021-01-30 14:46:32 +0100
commit00bf2c0cbe1c6c9625dbb7a6a58042a08539f073 (patch)
tree4a83a34d5d390ed5280545154d63324ccb14a2f7 /package/boot
parent24b910dca2d6a241d36da052a5067680c823cb04 (diff)
downloadupstream-00bf2c0cbe1c6c9625dbb7a6a58042a08539f073.tar.gz
upstream-00bf2c0cbe1c6c9625dbb7a6a58042a08539f073.tar.bz2
upstream-00bf2c0cbe1c6c9625dbb7a6a58042a08539f073.zip
arm-trusted-firmware-mvebu: don't build emmc variants
Starting with u-boot v2021.01 a single binary will be used for non-emmc and emmc variants. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/arm-trusted-firmware-mvebu/Makefile55
1 files changed, 0 insertions, 55 deletions
diff --git a/package/boot/arm-trusted-firmware-mvebu/Makefile b/package/boot/arm-trusted-firmware-mvebu/Makefile
index 1f84b8eb19..7778a26158 100644
--- a/package/boot/arm-trusted-firmware-mvebu/Makefile
+++ b/package/boot/arm-trusted-firmware-mvebu/Makefile
@@ -46,16 +46,6 @@ define Trusted-Firmware-A/espressobin-v3-v5-1gb-1cs
PLAT:=a3700
endef
-define Trusted-Firmware-A/espressobin-v3-v5-1gb-1cs-emmc
- NAME:=Marvell ESPRESSObin V3-V5 (1GB 1CS, eMMC)
- DEPENDS:=+u-boot-espressobin-emmc
- BUILD_DEVICES:=globalscale_espressobin-emmc
- UBOOT:=espressobin-emmc
- DDR_TOPOLOGY:=4
- CLOCKSPRESET:=CPU_800_DDR_800
- PLAT:=a3700
-endef
-
define Trusted-Firmware-A/espressobin-v3-v5-1gb-2cs
NAME:=Marvell ESPRESSObin V3-V5 (1GB, 2CS)
DEPENDS:=+u-boot-espressobin
@@ -66,16 +56,6 @@ define Trusted-Firmware-A/espressobin-v3-v5-1gb-2cs
PLAT:=a3700
endef
-define Trusted-Firmware-A/espressobin-v3-v5-1gb-2cs-emmc
- NAME:=Marvell ESPRESSObin V3-V5 (1GB 2CS, eMMC)
- DEPENDS:=+u-boot-espressobin-emmc
- BUILD_DEVICES:=globalscale_espressobin-emmc
- UBOOT:=espressobin-emmc
- DDR_TOPOLOGY:=2
- CLOCKSPRESET:=CPU_800_DDR_800
- PLAT:=a3700
-endef
-
define Trusted-Firmware-A/espressobin-v3-v5-2gb
NAME:=Marvell ESPRESSObin V3-V5 (2GB)
DEPENDS:=+u-boot-espressobin
@@ -86,16 +66,6 @@ define Trusted-Firmware-A/espressobin-v3-v5-2gb
PLAT:=a3700
endef
-define Trusted-Firmware-A/espressobin-v3-v5-2gb-emmc
- NAME:=Marvell ESPRESSObin V3-V5 (2GB, eMMC)
- DEPENDS:=+u-boot-espressobin-emmc
- BUILD_DEVICES:=globalscale_espressobin-emmc
- UBOOT:=espressobin-emmc
- DDR_TOPOLOGY:=7
- CLOCKSPRESET:=CPU_800_DDR_800
- PLAT:=a3700
-endef
-
define Trusted-Firmware-A/espressobin-v7-1gb
NAME:=Marvell ESPRESSObin V7 (1GB)
DEPENDS:=+u-boot-espressobin
@@ -106,16 +76,6 @@ define Trusted-Firmware-A/espressobin-v7-1gb
PLAT:=a3700
endef
-define Trusted-Firmware-A/espressobin-v7-1gb-emmc
- NAME:=Marvell ESPRESSObin V7 (1GB, eMMC)
- DEPENDS:=+u-boot-espressobin
- BUILD_DEVICES:=globalscale_espressobin-v7-emmc
- UBOOT:=espressobin-emmc
- DDR_TOPOLOGY:=5
- CLOCKSPRESET:=CPU_800_DDR_800
- PLAT:=a3700
-endef
-
define Trusted-Firmware-A/espressobin-v7-2gb
NAME:=Marvell ESPRESSObin V7 (2GB)
DEPENDS:=+u-boot-espressobin
@@ -126,16 +86,6 @@ define Trusted-Firmware-A/espressobin-v7-2gb
PLAT:=a3700
endef
-define Trusted-Firmware-A/espressobin-v7-2gb-emmc
- NAME:=Marvell ESPRESSObin V7 (2GB, eMMC)
- DEPENDS:=+u-boot-espressobin
- BUILD_DEVICES:=globalscale_espressobin-v7-emmc
- UBOOT:=espressobin-emmc
- DDR_TOPOLOGY:=6
- CLOCKSPRESET:=CPU_800_DDR_800
- PLAT:=a3700
-endef
-
define Trusted-Firmware-A/udpu
NAME:=Methode uDPU
DEPENDS:=+u-boot-uDPU
@@ -150,15 +100,10 @@ endef
TFA_TARGETS:= \
espressobin-512mb \
espressobin-v3-v5-1gb-1cs \
- espressobin-v3-v5-1gb-1cs-emmc \
espressobin-v3-v5-1gb-2cs \
- espressobin-v3-v5-1gb-2cs-emmc \
espressobin-v3-v5-2gb \
- espressobin-v3-v5-2gb-emmc \
espressobin-v7-1gb \
- espressobin-v7-1gb-emmc \
espressobin-v7-2gb \
- espressobin-v7-2gb-emmc \
udpu
TFA_MAKE_FLAGS += \