aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-zynq/Makefile
diff options
context:
space:
mode:
authorLuis Araneda <luaraneda@gmail.com>2018-09-03 22:39:59 -0300
committerJohn Crispin <john@phrozen.org>2018-09-10 08:54:41 +0200
commite2a4d14aaa562262dc27963a9f523aa18202cb56 (patch)
tree8a981d547d7a4590d1358bfb9626227b9ff19fbd /package/boot/uboot-zynq/Makefile
parent306a60fcfed2481498a05b9e016cba4abcfd1343 (diff)
downloadupstream-e2a4d14aaa562262dc27963a9f523aa18202cb56.tar.gz
upstream-e2a4d14aaa562262dc27963a9f523aa18202cb56.tar.bz2
upstream-e2a4d14aaa562262dc27963a9f523aa18202cb56.zip
uboot-zynq: use a file to modify the default environment
Follow the strategy of other targets and create a default environment file, uEnv.txt, to configure the behavior of U-Boot. For now, use it to pass bootargs to the kernel Signed-off-by: Luis Araneda <luaraneda@gmail.com>
Diffstat (limited to 'package/boot/uboot-zynq/Makefile')
-rw-r--r--package/boot/uboot-zynq/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/boot/uboot-zynq/Makefile b/package/boot/uboot-zynq/Makefile
index 31575d7cae..2e4c6cc034 100644
--- a/package/boot/uboot-zynq/Makefile
+++ b/package/boot/uboot-zynq/Makefile
@@ -20,6 +20,7 @@ define U-Boot/Default
BUILD_TARGET:=zynq
UBOOT_IMAGE:=spl/boot.bin u-boot.img
UBOOT_CONFIG:=zynq_$(1)
+ UENV:=default
HIDDEN:=1
endef
@@ -53,6 +54,7 @@ define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
$(CP) $(PKG_BUILD_DIR)/spl/boot.bin $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)-boot.bin
$(CP) $(PKG_BUILD_DIR)/u-boot.img $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)-u-boot.img
+ $(CP) ./files/uEnv-$(UENV).txt $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)-uEnv.txt
endef
define Package/u-boot/install/default