aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-sunxi
diff options
context:
space:
mode:
authorFan Fan <fkpwolf@gmail.com>2018-03-19 17:52:46 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2018-03-23 23:53:20 +0100
commit8e1065d681daff321f715ce5c6c172c12036bd6f (patch)
tree535ae2f44ed97a37bac9026341b7984058515cf8 /package/boot/uboot-sunxi
parent43788a91fb61bdf869e2ca68841ae34e422961d6 (diff)
downloadupstream-8e1065d681daff321f715ce5c6c172c12036bd6f.tar.gz
upstream-8e1065d681daff321f715ce5c6c172c12036bd6f.tar.bz2
upstream-8e1065d681daff321f715ce5c6c172c12036bd6f.zip
sunxi: add build for sopine
This will generate image for Pine64 Sopine board. Signed-off-by: Fan Fan <fkpwolf@gmail.com>
Diffstat (limited to 'package/boot/uboot-sunxi')
-rw-r--r--package/boot/uboot-sunxi/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 90cf102707..5257a41ad2 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -190,6 +190,15 @@ define U-Boot/pine64_plus
UENV:=a64
endef
+define U-Boot/sopine_baseboard
+ BUILD_SUBTARGET:=cortexa53
+ NAME:=Sopine Baseboard
+ BUILD_DEVICES:=sun50i-a64-sopine-baseboard
+ DEPENDS:=+PACKAGE_u-boot-sopine_baseboard:arm-trusted-firmware-sunxi
+ UENV:=a64
+endef
+
+
define U-Boot/orangepi_zero_plus
BUILD_SUBTARGET:=cortexa53
NAME:=Xunlong Orange Pi Zero Plus
@@ -226,6 +235,7 @@ UBOOT_TARGETS := \
orangepi_2 \
pangolin \
pine64_plus \
+ sopine_baseboard \
orangepi_zero_plus
UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes