aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-sunxi
diff options
context:
space:
mode:
authorAntony Antony <antony@phenome.org>2017-12-28 18:21:15 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-02-17 01:15:24 +0100
commit3c24a1d423a6052b101c00cb7d94e70d72702639 (patch)
tree663f8e2203e3352bbacb72c6ddf8aba19338799b /package/boot/uboot-sunxi
parentb7a1aa4df2a9834bb7339712670abbe1a05dc01c (diff)
downloadupstream-3c24a1d423a6052b101c00cb7d94e70d72702639.tar.gz
upstream-3c24a1d423a6052b101c00cb7d94e70d72702639.tar.bz2
upstream-3c24a1d423a6052b101c00cb7d94e70d72702639.zip
sunxi: add support for NanoPi NEO Plus2 board
arm64: allwinner: h5: NanoPi NEO Plus2 DT support Add initial DT for NanoPi NEO Plus2 by FriendlyARM - Allwinner quad core H5 Cortex A53 with an ARM Mali-450MP GPU - 1 GB DDR3 RAM - 8GB eMMC flash (Samsung KLM8G1WEPD-B031) - micro SD card slot - Gigabit Ethernet (external RTL8211E-VB-CG chip) - 802.11 b/g/n WiFi, Bluetooth 4.0 (Ampak AP6212A module) - 2x USB 2.0 host ports & 2x USB via headers Signed-off-by: Antony Antony <antony@phenome.org>
Diffstat (limited to 'package/boot/uboot-sunxi')
-rw-r--r--package/boot/uboot-sunxi/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 056300e189..321e7e9c03 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -168,6 +168,14 @@ define U-Boot/pangolin
UENV:=pangolin
endef
+define U-Boot/nanopi_neo_plus2
+ BUILD_SUBTARGET:=cortexa53
+ NAME:=NanoPi NEO Plus2 (H5)
+ BUILD_DEVICES:=sun50i-h5-nanopi-neo-plus2
+ DEPENDS:=+PACKAGE_u-boot-nanopi_neo_plus2:arm-trusted-firmware-sunxi
+ UENV:=a64
+endef
+
define U-Boot/pine64_plus
BUILD_SUBTARGET:=cortexa53
NAME:=Pine64 Plus A64
@@ -197,6 +205,7 @@ UBOOT_TARGETS := \
Lamobo_R1 \
nanopi_m1_plus \
nanopi_neo \
+ nanopi_neo_plus2 \
orangepi_r1 \
orangepi_plus \
orangepi_2 \