aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-sunxi/Makefile
diff options
context:
space:
mode:
authorArturas Moskvinas <arturas.moskvinas@gmail.com>2020-08-11 23:03:53 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2020-10-11 18:29:26 +0200
commit679db02b10474e8a685baeecc37ddd511f1d4808 (patch)
treec7a0602059950aee8bb4dfe927cf0d59f2ce9ef1 /package/boot/uboot-sunxi/Makefile
parent37e62ec4ec811cb6d2c8c0b25202ad551e035413 (diff)
downloadupstream-679db02b10474e8a685baeecc37ddd511f1d4808.tar.gz
upstream-679db02b10474e8a685baeecc37ddd511f1d4808.tar.bz2
upstream-679db02b10474e8a685baeecc37ddd511f1d4808.zip
sunxi: add support for FriendlyArm Zeropi
Specification CPU: Allwinner H3, Quad-core Cortex-A7 Up to 1.2GHz DDR3 RAM: 256MB/512MB Connectivity: 10/100/1000Mbps Ethernet USB Host: Type-A x 1 MicroSD Slot x 1 MicroUSB: for power input only Debug Serial Port: 4Pin, 2.54 mm pitch pin header Power Supply: DC 5V/2A PCB Dimension: 40 x 40 x 1.2mm Installation: Burn the image file to an SD Card with dd or any image burning tool Boot ZeroPi from the SD Card The following features are working and tested: Ethernet port 10/100/1000M Ethernet Remarks: SBC is mostly compatible and boots with FriendlyARM NanoPI M1 plus DTS also (zeropi has no working hdmi) Signed-off-by: Arturas Moskvinas <arturas.moskvinas@gmail.com>
Diffstat (limited to 'package/boot/uboot-sunxi/Makefile')
-rw-r--r--package/boot/uboot-sunxi/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index ac2f9de888..4363445114 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -154,6 +154,12 @@ define U-Boot/nanopi_m1_plus
BUILD_DEVICES:=friendlyarm_nanopi-m1-plus
endef
+define U-Boot/zeropi
+ BUILD_SUBTARGET:=cortexa7
+ NAME:=ZeroPi (H3)
+ BUILD_DEVICES:=friendlyarm_zeropi
+endef
+
define U-Boot/nanopi_neo_air
BUILD_SUBTARGET:=cortexa7
NAME:=U-Boot for NanoPi NEO Air (H3)
@@ -299,6 +305,7 @@ UBOOT_TARGETS := \
Linksprite_pcDuino3 \
Lamobo_R1 \
nanopi_m1_plus \
+ zeropi \
nanopi_neo \
nanopi_neo_air \
nanopi_neo_plus2 \