aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-oxnas/src/board/ox820/spl_start.S
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-23 12:40:32 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-24 16:21:25 +0100
commitbb88ec947fc7f4db6ada9ccccb0c4d09c75742b0 (patch)
tree192ce26a517d60b19740bc30a2c2aaa821589cc7 /package/boot/uboot-oxnas/src/board/ox820/spl_start.S
parent12bfa1c425e5012e063b0afd9a09d2dfefc20eee (diff)
downloadupstream-bb88ec947fc7f4db6ada9ccccb0c4d09c75742b0.tar.gz
upstream-bb88ec947fc7f4db6ada9ccccb0c4d09c75742b0.tar.bz2
upstream-bb88ec947fc7f4db6ada9ccccb0c4d09c75742b0.zip
uboot-oxnas: switch to u-boot.mk
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/boot/uboot-oxnas/src/board/ox820/spl_start.S')
-rw-r--r--package/boot/uboot-oxnas/src/board/ox820/spl_start.S21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/boot/uboot-oxnas/src/board/ox820/spl_start.S b/package/boot/uboot-oxnas/src/board/ox820/spl_start.S
new file mode 100644
index 0000000000..2eab3f56d8
--- /dev/null
+++ b/package/boot/uboot-oxnas/src/board/ox820/spl_start.S
@@ -0,0 +1,21 @@
+.section .init
+.globl _spl_start
+_spl_start:
+ b _start
+ b _start+0x4
+ b _start+0x8
+ b _start+0xc
+ b _start+0x10
+ b _start+0x14
+ b _start+0x18
+ b _start+0x1c
+ .space 0x30 - (. - _spl_start)
+ .ascii "BOOT" /* 0x30 signature*/
+ .word 0x50 /* 0x34 header size itself */
+ .word 0 /* 0x38 */
+ .word 0x5000f000 /* boot report location */
+ .word _start /* 0x40 */
+
+main_crc_size: .word code_size /* 0x44 filled by linker */
+main_crc: .word 0 /* 0x48 fill later */
+header_crc: .word 0 /* 0x4C header crc*/