aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-omap
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2017-04-15 18:49:57 +0200
committerAlexander Couzens <lynxis@fe80.eu>2017-04-24 18:03:31 +0200
commite2caa74a2ffece85c302960f4994776427db4e38 (patch)
treee633797a02cea6ee0f0c811454e9ff75d0270f33 /package/boot/uboot-omap
parent4ac4148cc4c7ffe8520da031fa9dec7704a224a0 (diff)
downloadupstream-e2caa74a2ffece85c302960f4994776427db4e38.tar.gz
upstream-e2caa74a2ffece85c302960f4994776427db4e38.tar.bz2
upstream-e2caa74a2ffece85c302960f4994776427db4e38.zip
package/uboot-omap: install image to STAGING_DIR_IMAGE
to use them later by image/Makefile to create full working sdcard images Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'package/boot/uboot-omap')
-rw-r--r--package/boot/uboot-omap/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/boot/uboot-omap/Makefile b/package/boot/uboot-omap/Makefile
index 876d9f0574..17a4af42f2 100644
--- a/package/boot/uboot-omap/Makefile
+++ b/package/boot/uboot-omap/Makefile
@@ -42,4 +42,9 @@ endef
UBOOT_TARGETS:=omap4_panda am335x_evm omap3_overo omap3_beagle
+define Build/InstallDev
+ $(INSTALL_DIR) $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)
+ $(CP) $(patsubst %,$(PKG_BUILD_DIR)/%,$(UBOOT_IMAGE)) $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)/
+endef
+
$(eval $(call BuildPackage/U-Boot))