aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2017-04-18 20:15:59 +0200
committerAlexander Couzens <lynxis@fe80.eu>2017-04-24 18:03:31 +0200
commit147e18bdbdb5ac093d06c3a7e400b20969b7a5f5 (patch)
tree220d30ab2d507423c20a805d993e8cdaee7321e8 /package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch
parente2caa74a2ffece85c302960f4994776427db4e38 (diff)
downloadupstream-147e18bdbdb5ac093d06c3a7e400b20969b7a5f5.tar.gz
upstream-147e18bdbdb5ac093d06c3a7e400b20969b7a5f5.tar.bz2
upstream-147e18bdbdb5ac093d06c3a7e400b20969b7a5f5.zip
package/uboot-omap: re-introduce patches dropped by update to v2017.01
The beagleboard doesn't boot with Thumb enabled, but without Thumb the SPL (first stage bootloader) is too big to fit into SRAM. Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch')
-rw-r--r--package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch b/package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch
new file mode 100644
index 0000000000..89b02044dc
--- /dev/null
+++ b/package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch
@@ -0,0 +1,27 @@
+Index: u-boot-2017.01/fs/fat/Makefile
+===================================================================
+--- u-boot-2017.01.orig/fs/fat/Makefile
++++ u-boot-2017.01/fs/fat/Makefile
+@@ -4,8 +4,8 @@
+ #
+
+ obj-$(CONFIG_FS_FAT) := fat.o
+-obj-$(CONFIG_FAT_WRITE):= fat_write.o
+
+ ifndef CONFIG_SPL_BUILD
++obj-$(CONFIG_FAT_WRITE):= fat_write.o
+ obj-$(CONFIG_FS_FAT) += file.o
+ endif
+Index: u-boot-2017.01/fs/fat/fat.c
+===================================================================
+--- u-boot-2017.01.orig/fs/fat/fat.c
++++ u-boot-2017.01/fs/fat/fat.c
+@@ -163,7 +163,7 @@ static void get_name(dir_entry *dirent,
+ }
+
+ static int flush_dirty_fat_buffer(fsdata *mydata);
+-#if !defined(CONFIG_FAT_WRITE)
++#if !defined(CONFIG_FAT_WRITE) || defined(CONFIG_SPL_BUILD)
+ /* Stub for read only operation */
+ int flush_dirty_fat_buffer(fsdata *mydata)
+ {