aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mxs/patches/210-link-libcrypto-static.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-04-29 00:40:40 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-04-29 00:57:36 +0200
commitc21a4c724662cd9bac23456320314a995cb3c802 (patch)
tree8a04a440fac804a121f6e9167f79e7e2f31920f7 /package/boot/uboot-mxs/patches/210-link-libcrypto-static.patch
parent5ca159ab3b36c97197bff6a50f65e1666a8f78ec (diff)
downloadupstream-c21a4c724662cd9bac23456320314a995cb3c802.tar.gz
upstream-c21a4c724662cd9bac23456320314a995cb3c802.tar.bz2
upstream-c21a4c724662cd9bac23456320314a995cb3c802.zip
uboot-mxs: Fix build with libressl 2.7.2
When libressl was linked the libpthread was missing, add it in addition. Also make the mxsimage tool to use the OpenSSL 1.1 API for the recent libressl version. Fixes: 2c192b69163f ("tools/libressl: update to version 2.7.2") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/boot/uboot-mxs/patches/210-link-libcrypto-static.patch')
-rw-r--r--package/boot/uboot-mxs/patches/210-link-libcrypto-static.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/boot/uboot-mxs/patches/210-link-libcrypto-static.patch b/package/boot/uboot-mxs/patches/210-link-libcrypto-static.patch
new file mode 100644
index 0000000000..87b70ccea4
--- /dev/null
+++ b/package/boot/uboot-mxs/patches/210-link-libcrypto-static.patch
@@ -0,0 +1,14 @@
+OpenWrt links the libressl statically against mkimage, make sure all the
+needed dependencies are added too.
+
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -163,7 +163,7 @@ endif
+ # MXSImage needs LibSSL
+ ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CONFIG_ARMADA_38X)$(CONFIG_ARMADA_39X)$(CONFIG_FIT_SIGNATURE),)
+ HOSTLOADLIBES_mkimage += \
+- $(shell pkg-config --libs libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
++ $(shell pkg-config --libs --static libssl libcrypto 2> /dev/null || echo "-lssl -lpthread -lcrypto")
+
+ # OS X deprecate openssl in favour of CommonCrypto, supress deprecation
+ # warnings on those systems