aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mvebu
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2020-09-23 02:59:47 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2020-10-11 16:38:16 +0200
commit8870ad58b6ed2a93786326a41c61dc54470ab6a3 (patch)
tree291e191d2f19002564c458f34f6c52ec084f092c /package/boot/uboot-mvebu
parent1d234cfdfdfdf9c56e8c5ebadeda57997ad87dfe (diff)
downloadupstream-8870ad58b6ed2a93786326a41c61dc54470ab6a3.tar.gz
upstream-8870ad58b6ed2a93786326a41c61dc54470ab6a3.tar.bz2
upstream-8870ad58b6ed2a93786326a41c61dc54470ab6a3.zip
uboot-mvebu: don't install 64bit binaries
u-boot binaries are not useful for these boards, they need to be combined with atf for a proper firmware. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/boot/uboot-mvebu')
-rw-r--r--package/boot/uboot-mvebu/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/boot/uboot-mvebu/Makefile b/package/boot/uboot-mvebu/Makefile
index 903b9da5ff..25dd2526e5 100644
--- a/package/boot/uboot-mvebu/Makefile
+++ b/package/boot/uboot-mvebu/Makefile
@@ -70,6 +70,10 @@ define Build/Configure
$(call Build/Configure/U-Boot)
endef
+define Package/u-boot/install
+ $(if $(findstring cortexa53,$(BUILD_SUBTARGET)),,$(Package/u-boot/install/default))
+endef
+
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
$(CP) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-$(UBOOT_IMAGE)