aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mvebu/patches
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-04-29 10:12:14 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-04-29 10:13:14 +0200
commit9bfca308268ec0e5f5f501f6224f9a948ade1036 (patch)
tree1316d327322f3c564d1c557ff7398edf3c1a1f58 /package/boot/uboot-mvebu/patches
parentc21a4c724662cd9bac23456320314a995cb3c802 (diff)
downloadupstream-9bfca308268ec0e5f5f501f6224f9a948ade1036.tar.gz
upstream-9bfca308268ec0e5f5f501f6224f9a948ade1036.tar.bz2
upstream-9bfca308268ec0e5f5f501f6224f9a948ade1036.zip
uboot-mvebu: Fix build with libressl 2.7.2
When libressl was linked the libpthread was missing, add it in addition. Fixes: 2c192b69163f ("tools/libressl: update to version 2.7.2") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/boot/uboot-mvebu/patches')
-rw-r--r--package/boot/uboot-mvebu/patches/210-link-libcrypto-static.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/boot/uboot-mvebu/patches/210-link-libcrypto-static.patch b/package/boot/uboot-mvebu/patches/210-link-libcrypto-static.patch
new file mode 100644
index 0000000000..ee6c73f469
--- /dev/null
+++ b/package/boot/uboot-mvebu/patches/210-link-libcrypto-static.patch
@@ -0,0 +1,14 @@
+OpenWrt links the libressl statically against mkimage, make sure all the
+needed dependencies are added too.
+
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -145,7 +145,7 @@ endif
+ # MXSImage needs LibSSL
+ ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CONFIG_ARMADA_38X)$(CONFIG_ARMADA_39X)$(CONFIG_FIT_SIGNATURE),)
+ HOSTLOADLIBES_mkimage += \
+- $(shell pkg-config --libs libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
++ $(shell pkg-config --libs --static libssl libcrypto 2> /dev/null || echo "-lssl -lpthread -lcrypto")
+
+ # OS X deprecate openssl in favour of CommonCrypto, supress deprecation
+ # warnings on those systems