aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mediatek/Makefile
diff options
context:
space:
mode:
authorHank Moretti <mchank9999@gmail.com>2023-07-20 17:42:58 +0000
committerDaniel Golle <daniel@makrotopia.org>2023-08-07 16:31:27 +0100
commitd0fc9e96be5a26869ee0d273894889e21651865c (patch)
tree92a05b7dddfd7858a3d863ee94a1c2502558a201 /package/boot/uboot-mediatek/Makefile
parentc697057b7ca17b5c80bcfb266e7c00eb699c8608 (diff)
downloadupstream-d0fc9e96be5a26869ee0d273894889e21651865c.tar.gz
upstream-d0fc9e96be5a26869ee0d273894889e21651865c.tar.bz2
upstream-d0fc9e96be5a26869ee0d273894889e21651865c.zip
uboot-mediatek: add support for Xiaomi WR30U
Add a custom uboot build to support openwrt uboot layout. Signed-off-by: Hank Moretti <mchank9999@gmail.com>
Diffstat (limited to 'package/boot/uboot-mediatek/Makefile')
-rw-r--r--package/boot/uboot-mediatek/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/boot/uboot-mediatek/Makefile b/package/boot/uboot-mediatek/Makefile
index 33fd7e086e..55965e64db 100644
--- a/package/boot/uboot-mediatek/Makefile
+++ b/package/boot/uboot-mediatek/Makefile
@@ -200,6 +200,18 @@ define U-Boot/mt7981_qihoo_360t7
DEPENDS:=+trusted-firmware-a-mt7981-spim-nand-ddr3
endef
+define U-Boot/mt7981_xiaomi_mi-router-wr30u
+ NAME:=Xiaomi Router WR30U
+ BUILD_SUBTARGET:=filogic
+ BUILD_DEVICES:=xiaomi_mi-router-wr30u-ubootmod
+ UBOOT_CONFIG:=mt7981_xiaomi_mi-router-wr30u
+ UBOOT_IMAGE:=u-boot.fip
+ BL2_BOOTDEV:=spim-nand
+ BL2_SOC:=mt7981
+ BL2_DDRTYPE:=ddr3
+ DEPENDS:=+trusted-firmware-a-mt7981-spim-nand-ddr3
+endef
+
define U-Boot/mt7986_rfb
NAME:=MT7986 Reference Board
BUILD_SUBTARGET:=filogic
@@ -327,6 +339,7 @@ UBOOT_TARGETS := \
mt7629_rfb \
mt7981_h3c_magic-nx30-pro \
mt7981_qihoo_360t7 \
+ mt7981_xiaomi_mi-router-wr30u \
mt7986_bananapi_bpi-r3-emmc \
mt7986_bananapi_bpi-r3-sdmmc \
mt7986_bananapi_bpi-r3-snand \