aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-layerscape/Makefile
diff options
context:
space:
mode:
authorYutang Jiang <yutang.jiang@nxp.com>2016-12-01 23:01:27 +0800
committerJohn Crispin <john@phrozen.org>2016-12-12 09:57:40 +0100
commitd5fc7430ca293213dd4f1de7f52446c17d4def6a (patch)
tree4d884312e45871f219a0f1993c80299cc1cc61a6 /package/boot/uboot-layerscape/Makefile
parentb0ac825884e7bfe3f68385109df3234e37022c71 (diff)
downloadupstream-d5fc7430ca293213dd4f1de7f52446c17d4def6a.tar.gz
upstream-d5fc7430ca293213dd4f1de7f52446c17d4def6a.tar.bz2
upstream-d5fc7430ca293213dd4f1de7f52446c17d4def6a.zip
layerscape: uboot-layerscape: prefer github over git.freescale.com
In order to prevent the impact of the merger of the company and the potential rebase of the SDK repositories, migrate the u-boot source to github. Signed-off-by: Yutang Jiang <yutang.jiang@nxp.com>
Diffstat (limited to 'package/boot/uboot-layerscape/Makefile')
-rw-r--r--package/boot/uboot-layerscape/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/package/boot/uboot-layerscape/Makefile b/package/boot/uboot-layerscape/Makefile
index dd9ade61c1..17fd7f97b0 100644
--- a/package/boot/uboot-layerscape/Makefile
+++ b/package/boot/uboot-layerscape/Makefile
@@ -8,14 +8,17 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-PKG_NAME:=fsl-sdk
-PKG_VERSION:=v2.0
+PKG_NAME:=uboot-layerscape
+PKG_VERSION:=v1.0
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:= \
- http://git.freescale.com/git/cgit.cgi/ppc/sdk/u-boot.git/snapshot
-PKG_MD5SUM:=14f7ccc757bfa71c9b7fd68d24051231
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=https://github.com/fsl-jyt/u-boot.git
+PKG_SOURCE_VERSION:=aefcbf4c2bb36e1f0ead61181e5fe1119b5683ad
-PKG_BUILD_DIR:=$(BUILD_DIR)/u-boot_$(PKG_NAME)-$(PKG_VERSION)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_LICENSE:=GPL-2.0 GPL-2.0+
PKG_LICENSE_FILES:=Licenses/README