aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-layerscape/Makefile
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2018-07-18 16:56:07 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2018-09-22 21:20:57 +0200
commit7016dd48f164364e1ee7b9d86169375691f7be0d (patch)
treea8bb408214ca6cbb8cb7b764d79803488310a72e /package/boot/uboot-layerscape/Makefile
parenteb684205e5e6958ad71cf4a179fa776f6507f7e3 (diff)
downloadupstream-7016dd48f164364e1ee7b9d86169375691f7be0d.tar.gz
upstream-7016dd48f164364e1ee7b9d86169375691f7be0d.tar.bz2
upstream-7016dd48f164364e1ee7b9d86169375691f7be0d.zip
layerscape: add ls1012afrwy support and drop ls1012afrdm
ls1012afrdm was no longer supported in NXP Layerscape SDK. Instead a new board ls1012afrwy was introduced in LSDK. This patch is to drop ls1012afrdm and add ls1012afrwy support. Since only 2MB NOR flash could be used, we just put u-boot and firmware on NOR flash, and put kernel/dtb/rootfs on SD card. The Layerscape FRWY-LS1012A board is an ultra-low-cost development platform for LS1012A Series Communication Processors built on Arm Cortex-A53. This tool refines the FRDM-LS1012A with more features for a better hands-on experience for IoT, edge computing, and various advanced embedded applications. Features include easy access to processor I/O, low-power operation, micro SD card storage, an M2 connector, a small form factor, and expansion board options via mikroBUS Click Module. The MicroBUS Module provides easy expansion via hundreds of powerful modules supporting sensors, actuators, memories, and displays. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'package/boot/uboot-layerscape/Makefile')
-rw-r--r--package/boot/uboot-layerscape/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/boot/uboot-layerscape/Makefile b/package/boot/uboot-layerscape/Makefile
index ef456bfc7e..39dc6c76d1 100644
--- a/package/boot/uboot-layerscape/Makefile
+++ b/package/boot/uboot-layerscape/Makefile
@@ -33,10 +33,10 @@ define U-Boot/ls1012ardb
ENV_SIZE:=0x40000
endef
-define U-Boot/ls1012afrdm
- NAME:=NXP LS1012AFRDM
- UBOOT_CONFIG:=ls1012afrdm_qspi
- ENV_SIZE:=0x40000
+define U-Boot/ls1012afrwy
+ NAME:=NXP LS1012AFRWY
+ UBOOT_CONFIG:=ls1012afrwy_qspi
+ ENV_SIZE:=0x10000
endef
define U-Boot/ls1043ardb
@@ -94,7 +94,7 @@ endef
UBOOT_TARGETS := \
ls1012ardb \
- ls1012afrdm \
+ ls1012afrwy \
ls1043ardb \
ls1043ardb-sdboot \
ls1046ardb \