aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-layerscape/Makefile
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2020-02-25 20:07:36 +0100
committerPetr Štetiar <ynezz@true.cz>2020-03-12 12:59:44 +0100
commit3a3d998c129c3316c188b1abd9b2d3b0fc82ab2e (patch)
tree2b254548a57ea46d4065c0fc2818f75d23b086c2 /package/boot/uboot-layerscape/Makefile
parent4ec2f33bfea560ecfa6b75e13abc515fe90d76a4 (diff)
downloadupstream-3a3d998c129c3316c188b1abd9b2d3b0fc82ab2e.tar.gz
upstream-3a3d998c129c3316c188b1abd9b2d3b0fc82ab2e.tar.bz2
upstream-3a3d998c129c3316c188b1abd9b2d3b0fc82ab2e.zip
layerscape: resurrect support for FRDM-LS1012A
Re-add support for NXP FRDM-LS1012A, which mimics the flash layout of the rest boards supported by LSDK. 0x000000000000-0x000000100000 : "bl2" 0x000000100000-0x000000500000 : "fip" 0x000000500000-0x000000600000 : "u-boot-env" 0x000000600000-0x000000a00000 : "reserved-1" 0x000000a00000-0x000000d00000 : "pfe" 0x000000d00000-0x000000f00000 : "reserved-2" 0x000000f00000-0x000001000000 : "dtb" 0x000001000000-0x000002000000 : "kernel" 0x000002000000-0x000004000000 : "ubifs" Specification SoC: LS1012A single core 800MHz RAM: 512 MB DDR3 Flash: 64 MB QSPI NOR Ethernet: 2x 10/100/1000 Mbps Connectors: µUSB 3.0 OTG µUSB 2.0 (debugging & power input) 2x 3.5mm jack for microphone & headphone (SGTL5000) Arduino Shield expansion with I2C, SPI, UART, and GPIO JTAG LEDS: 3x (non-configurable) Buttons: 1x (reset, non-configurable) Be advised that erasing or writing 64MB flash takes some time to finish. Do not reset the board until all operations end with success, otherwise You'll need external tools to re-program the flash chip. Installation Follow the QSPI programing procedure for LS1012AFRWY board in target/linux/layerscape/README, point 3.3. Don't forget about updating U-Boot environment with MAC addresses of ethernet interfaces, variable 'ethaddr' for eth0 and 'eth1addr' for eth1. As the LSDK images do not support sysupgrade, nor do changes in this commit, it's planed in upcoming submissions. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'package/boot/uboot-layerscape/Makefile')
-rw-r--r--package/boot/uboot-layerscape/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/boot/uboot-layerscape/Makefile b/package/boot/uboot-layerscape/Makefile
index ddf71bd986..63c16a7db0 100644
--- a/package/boot/uboot-layerscape/Makefile
+++ b/package/boot/uboot-layerscape/Makefile
@@ -27,6 +27,12 @@ define U-Boot/Default
ENV_SIZE:=0x2000
endef
+define U-Boot/ls1012afrdm
+ NAME:=NXP LS1012AFRDM
+ UBOOT_CONFIG:=ls1012afrdm_tfa
+ ENV_SIZE:=0x40000
+endef
+
define U-Boot/ls1012ardb
NAME:=NXP LS1012ARDB
UBOOT_CONFIG:=ls1012ardb_tfa
@@ -102,6 +108,7 @@ endef
UBOOT_TARGETS := \
+ ls1012afrdm \
ls1012ardb \
ls1012afrwy \
ls1043ardb \