aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-layerscape/Makefile
diff options
context:
space:
mode:
authorBiwen Li <biwen.li@nxp.com>2018-11-02 18:30:57 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2018-12-18 20:17:23 +0100
commit328530c6e7569d7be24e3524483f4453910003e9 (patch)
tree90ec1f99796fb88ebffb69380eb5adc0e60f34b8 /package/boot/uboot-layerscape/Makefile
parent0a827ebd2fa3c7dc210aff0a30d0dc1d536ed89c (diff)
downloadupstream-328530c6e7569d7be24e3524483f4453910003e9.tar.gz
upstream-328530c6e7569d7be24e3524483f4453910003e9.tar.bz2
upstream-328530c6e7569d7be24e3524483f4453910003e9.zip
layerscape: add LS1021AIOT board support
The LS1021A-IoT gateway reference design based on the QorIQ LS1021A processor is a purpose-built, small footprint hardware platform with a wide array of high-speed connectivity and low-speed serial interfaces to support secure delivery of IoT services for home, business or other commercial location. - Combines standards-based, open source software with a feature-rich IoT gateway design to establish a common, open framework for secured IoT service delivery and management. - Provides a wide assortment of high-speed and serial-based connectivity in a compact, highly secure design. - High efficiency through the use of the Arm-based QorIQ LS1021A embedded processor. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com> Signed-off-by: Biwen Li <biwen.li@nxp.com>
Diffstat (limited to 'package/boot/uboot-layerscape/Makefile')
-rw-r--r--package/boot/uboot-layerscape/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/package/boot/uboot-layerscape/Makefile b/package/boot/uboot-layerscape/Makefile
index 39dc6c76d1..911d9696e6 100644
--- a/package/boot/uboot-layerscape/Makefile
+++ b/package/boot/uboot-layerscape/Makefile
@@ -92,6 +92,15 @@ define U-Boot/ls1021atwr-sdboot
ENV_SIZE:=0x20000
endef
+define U-Boot/ls1021aiot-sdboot
+ NAME:=NXP LS1021AIOT SD Card Boot
+ BUILD_SUBTARGET:=armv7
+ UBOOT_CONFIG:=ls1021aiot_sdcard
+ UBOOT_IMAGE:=u-boot-with-spl-pbl.bin
+ ENV_SIZE:=0x2000
+endef
+
+
UBOOT_TARGETS := \
ls1012ardb \
ls1012afrwy \
@@ -103,7 +112,8 @@ UBOOT_TARGETS := \
ls1088ardb-sdboot \
ls2088ardb \
ls1021atwr \
- ls1021atwr-sdboot
+ ls1021atwr-sdboot \
+ ls1021aiot-sdboot
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)