aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-layerscape-armv8_32b/Makefile
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2018-07-04 12:20:41 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2018-09-22 21:20:56 +0200
commitdcf57c766acc5224e05f62cf5fae2d965abace59 (patch)
tree2925da645e9836eca4af550729cc693853dec1c2 /package/boot/uboot-layerscape-armv8_32b/Makefile
parente83faa3d7d5cd8fe8753e86bd25e04fd61b70490 (diff)
downloadupstream-dcf57c766acc5224e05f62cf5fae2d965abace59.tar.gz
upstream-dcf57c766acc5224e05f62cf5fae2d965abace59.tar.bz2
upstream-dcf57c766acc5224e05f62cf5fae2d965abace59.zip
layerscape: update u-boot to LSDK-18.06
The u-boot source code had been migrated to codeaurora for LSDK-18.06 release and the future release. This patch is to update u-boot to LSDK-18.06 for both uboot-layerscape and uboot-layerscape-armv8_32b packages. Besides, this patch also introduced some other changes. - Reworked uboot-layerscape makefile to make it more readable. - Define package in uboot-layerscape-armv8_32b for each board. - Fixed u-boot package selection in target image makefile. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'package/boot/uboot-layerscape-armv8_32b/Makefile')
-rw-r--r--package/boot/uboot-layerscape-armv8_32b/Makefile67
1 files changed, 45 insertions, 22 deletions
diff --git a/package/boot/uboot-layerscape-armv8_32b/Makefile b/package/boot/uboot-layerscape-armv8_32b/Makefile
index 3d3b684dc1..415d9bdbea 100644
--- a/package/boot/uboot-layerscape-armv8_32b/Makefile
+++ b/package/boot/uboot-layerscape-armv8_32b/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uboot-layerscape-armv8_32b
-PKG_SOURCE_DATE:=2018-01-22
+PKG_VERSION:=lsdk-1806
PKG_RELEASE:=1
# Layerscape ARMv8 platforms use 64-bit u-boot to support both 32-bit and 64-bit
@@ -17,37 +17,60 @@ PKG_RELEASE:=1
# uboot-layerscape's source code.
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/yangbolu1991/u-boot-lede.git
-PKG_SOURCE_VERSION:=40a40dfd8136fcc314dd442a3b24a41b1e5652dd
-PKG_MIRROR_HASH:=3dde5a33d19c573cbdce74f5d7edb6c5ca2a26a39d503c3efe5d5ad06f01e9f5
-
-PKG_MAINTAINER:=Yangbo Lu <yangbo.lu@nxp.com>
+PKG_SOURCE_VERSION:=a2a01facee0918bf724b4f0aec6746e2f1271519
+PKG_MIRROR_HASH:=5fcb58c14cdc934793ff315e178ad1d9d2ff55fcaac394b48ec116d1b11ca324
include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-define Package/uboot-layerscape-armv8_32b
- SECTION:=boot
- CATEGORY:=Boot Loaders
- DEPENDS:=@TARGET_layerscape_armv8_32b
- TITLE:=U-Boot for ARMv8 32-bit based Layerscape boards
- DEFAULT:=y
- HIDDEN:=1
+
+define Package/uboot-layerscape-armv8_32b/Config
+ define Package/u-boot-$(1)-image
+ SECTION:=boot
+ CATEGORY:=Boot Loaders
+ TITLE:=$(2)
+ DEPENDS:=@TARGET_layerscape_armv8_32b
+ CONFIG:=$(3)
+ endef
endef
-define Build/Configure
+define Package/uboot-layerscape-armv8_32b/ls1012ardb
+ TITLE:=U-Boot image for NXP LS1012ARDB
+ CONFIG:=ls1012ardb-uboot.bin
+endef
+define Package/uboot-layerscape-armv8_32b/ls1012afrdm
+ TITLE:=U-Boot image for NXP LS1012FRDM
+ CONFIG:=ls1012afrdm-uboot.bin
endef
-define Build/Compile
+define Package/uboot-layerscape-armv8_32b/ls1043ardb
+ TITLE:=U-Boot image for NXP LS1043ARDB
+ CONFIG:=ls1043ardb-uboot.bin
+endef
+define Package/uboot-layerscape-armv8_32b/ls1046ardb
+ TITLE:=U-Boot image for NXP LS1046ARDB
+ CONFIG:=ls1046ardb-uboot.bin
endef
-define Build/InstallDev
+define Build/Compile
+endef
+
+define Package/uboot-layerscape-armv8_32b/Install
+ define Package/u-boot-$(1)-image/install
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
- $(CP) $(PKG_BUILD_DIR)/ls1043ardb-uboot.bin $(STAGING_DIR_IMAGE)/ls1043ardb-armv8_32b-uboot.bin
- $(CP) $(PKG_BUILD_DIR)/ls1046ardb-uboot.bin $(STAGING_DIR_IMAGE)/ls1046ardb-armv8_32b-uboot.bin
- $(CP) $(PKG_BUILD_DIR)/ls1012ardb-uboot.bin $(STAGING_DIR_IMAGE)/ls1012ardb-armv8_32b-uboot.bin
- $(CP) $(PKG_BUILD_DIR)/ls1012afrdm-uboot.bin $(STAGING_DIR_IMAGE)/ls1012afrdm-armv8_32b-uboot.bin
+ $(CP) $(PKG_BUILD_DIR)/$(CONFIG) $(STAGING_DIR_IMAGE)/
+ endef
endef
-$(eval $(call BuildPackage,uboot-layerscape-armv8_32b))
+UBOOTS := \
+ ls1012ardb \
+ ls1012afrdm \
+ ls1043ardb \
+ ls1046ardb
+
+$(foreach u,$(UBOOTS), \
+ $(eval $(Package/uboot-layerscape-armv8_32b/$(u))) \
+ $(eval $(call Package/uboot-layerscape-armv8_32b/Config,$(u),$(TITLE),$(CONFIG))) \
+ $(eval $(call Package/uboot-layerscape-armv8_32b/Install,$(u))) \
+ $(eval $(call BuildPackage,u-boot-$(u)-image)) \
+)