aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-lantiq/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-06-05 14:11:45 +0000
committerJohn Crispin <john@openwrt.org>2015-06-05 14:11:45 +0000
commitbf4dbe05c6d202e924c15b88bf3ac34ead3803ce (patch)
tree4605bb3131e5cea8394f6402a7c4cc88097c4d72 /package/boot/uboot-lantiq/Makefile
parentca1db6b5ce5675d88b45b23f576e8c59f7f4fc48 (diff)
downloadupstream-bf4dbe05c6d202e924c15b88bf3ac34ead3803ce.tar.gz
upstream-bf4dbe05c6d202e924c15b88bf3ac34ead3803ce.tar.bz2
upstream-bf4dbe05c6d202e924c15b88bf3ac34ead3803ce.zip
uboot-lantiq: Add Arcadyan VGV7510KW22 support
This is already applied in Daniel's ("upstream") tree and thus will be part of upcoming version(s). SVN-Revision: 45898
Diffstat (limited to 'package/boot/uboot-lantiq/Makefile')
-rw-r--r--package/boot/uboot-lantiq/Makefile21
1 files changed, 20 insertions, 1 deletions
diff --git a/package/boot/uboot-lantiq/Makefile b/package/boot/uboot-lantiq/Makefile
index d59aac85d5..b396ab7e3f 100644
--- a/package/boot/uboot-lantiq/Makefile
+++ b/package/boot/uboot-lantiq/Makefile
@@ -257,6 +257,24 @@ define uboot/p2812hnufx_nandspl
DEPS:=@TARGET_lantiq_xrx200_P2812HNUF1||@TARGET_lantiq_xrx200_P2812HNUF3
endef
+define uboot/vgv7510kw22_brn
+ TITLE:=U-Boot for Arcadyan VGV7510KW22 (BRN)
+ SOC:=vr9
+ DEPS:=@TARGET_lantiq_xrx200_VGV7510KW22NOR||@TARGET_lantiq_xrx200_VGV7510KW22BRN
+endef
+
+define uboot/vgv7510kw22_nor
+ TITLE:=U-Boot for Arcadyan VGV7510KW22 (NOR)
+ SOC:=vr9
+ DEPS:=@TARGET_lantiq_xrx200_VGV7510KW22NOR||@TARGET_lantiq_xrx200_VGV7510KW22BRN
+endef
+
+define uboot/vgv7510kw22_ram
+ TITLE:=U-Boot for Arcadyan VGV7510KW22 (RAM)
+ SOC:=vr9
+ DDR_SETTINGS:=board/arcadyan/vgv7510kw22/ddr_settings.h
+ DEPS:=@TARGET_lantiq_xrx200_VGV7510KW22NOR||@TARGET_lantiq_xrx200_VGV7510KW22BRN
+endef
UBOOTS:= \
arv4519pw_ram arv4519pw_nor arv4519pw_brn \
@@ -270,7 +288,8 @@ UBOOTS:= \
easy50712_ram easy50712_nor easy50712_norspl \
easy80920_ram easy80920_nor easy80920_norspl easy80920_sfspl \
fb3370_eva fb3370_ram fb3370_sfspl \
- p2812hnufx_ram p2812hnufx_nandspl
+ p2812hnufx_ram p2812hnufx_nandspl \
+ vgv7510kw22_brn vgv7510kw22_nor vgv7510kw22_ram
define Package/uboot/template
define Package/uboot-lantiq-$(1)