aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-lantiq/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-06-20 18:47:39 +0200
committerJohn Crispin <john@phrozen.org>2016-06-22 19:32:06 +0200
commitb32eb40210f878a69d2eead06a7df6ee4d011bff (patch)
treef81251d48f2d00339de56e8e2feaf7adde3c2a6e /package/boot/uboot-lantiq/Makefile
parent9759fde40a3c50095097443ed261b5dd33f8b393 (diff)
downloadupstream-b32eb40210f878a69d2eead06a7df6ee4d011bff.tar.gz
upstream-b32eb40210f878a69d2eead06a7df6ee4d011bff.tar.bz2
upstream-b32eb40210f878a69d2eead06a7df6ee4d011bff.zip
uboot-lantiq: Add Arcadyan ARV7506PW11 support
Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'package/boot/uboot-lantiq/Makefile')
-rw-r--r--package/boot/uboot-lantiq/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/boot/uboot-lantiq/Makefile b/package/boot/uboot-lantiq/Makefile
index bb4f7db642..3ecc1a24cf 100644
--- a/package/boot/uboot-lantiq/Makefile
+++ b/package/boot/uboot-lantiq/Makefile
@@ -55,6 +55,25 @@ define uboot/arv4519pw_brn
DEPS:=@TARGET_lantiq_xway
endef
+define uboot/arv7506pw11_ram
+ TITLE:=U-Boot for Arcadyan ARV7506PW11 (RAM)
+ SOC:=danube
+ DDR_SETTINGS:=board/arcadyan/arv7506pw11/ddr_settings.h
+ DEPS:=@TARGET_lantiq_xway
+endef
+
+define uboot/arv7506pw11_nor
+ TITLE:=U-Boot for Arcadyan ARV7506PW11 (NOR)
+ SOC:=danube
+ DEPS:=@TARGET_lantiq_xway
+endef
+
+define uboot/arv7506pw11_brn
+ TITLE:=U-Boot for Arcadyan ARV7506PW11 (BRN)
+ SOC:=danube
+ DEPS:=@TARGET_lantiq_xway
+endef
+
define uboot/arv7510pw_ram
TITLE:=U-Boot for Arcadyan arv7510pw (RAM)
SOC:=danube
@@ -316,6 +335,7 @@ endef
UBOOTS:= \
arv4519pw_ram arv4519pw_nor arv4519pw_brn \
+ arv7506pw11_ram arv7506pw11_nor arv7506pw11_brn \
arv7510pw_ram arv7510pw_nor arv7510pw_brn \
arv7510pw22_ram arv7510pw22_nor arv7510pw22_brn \
arv7518pw_ram arv7518pw_nor arv7518pw_brn \