aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-lantiq/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-05-20 23:45:59 +0200
committerMathias Kresin <dev@kresin.me>2016-11-29 21:40:16 +0100
commit36148d923b72688f825f3c2c540942c91039f7d2 (patch)
tree0944a1b31e78afb1ef61c1fec94bbdb0071442fc /package/boot/uboot-lantiq/Makefile
parent0e34459e6b4d7b3753b27cf97f304f86e80155ca (diff)
downloadupstream-36148d923b72688f825f3c2c540942c91039f7d2.tar.gz
upstream-36148d923b72688f825f3c2c540942c91039f7d2.tar.bz2
upstream-36148d923b72688f825f3c2c540942c91039f7d2.zip
uboot-lantiq: Add BT Home Hub 5A support
Based on the submission to the uboot-lantiq repo by Martin Blumenstingl. Use the ddr_settings.h from the GPL tarball. The NAND boot optimized one (with memory tuning enabled) doesn't work for the UART boot image. Use the same mtd layout as the stock u-boot. Add add UBI support. Use the leds to indicate boot status like it is done with the stock u-boot. Switch on the red power led if kernel image can't be loaded. Otherwise switch the green led on. Make only the ramboot u-boot available. Only this image is required for the first installation of LEDE. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'package/boot/uboot-lantiq/Makefile')
-rw-r--r--package/boot/uboot-lantiq/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/boot/uboot-lantiq/Makefile b/package/boot/uboot-lantiq/Makefile
index 43f481fc2f..e34ba79140 100644
--- a/package/boot/uboot-lantiq/Makefile
+++ b/package/boot/uboot-lantiq/Makefile
@@ -214,6 +214,13 @@ define uboot/acmp252_nor
DEPS:=@TARGET_lantiq_xway
endef
+define uboot/bthomehubv5a_ram
+ TITLE:=U-Boot for BT Home Hub 5A (RAM)
+ SOC:=vr9
+ DDR_SETTINGS:=board/bt/bthomehubv5a/ddr_settings.h
+ DEPS:=@TARGET_lantiq_xrx200
+endef
+
define uboot/easy50712_ram
TITLE:=U-Boot for Lantiq EASY50712 (RAM)
SOC:=danube
@@ -342,6 +349,7 @@ UBOOTS:= \
arv752dpw_ram arv752dpw_nor arv752dpw_brn \
arv752dpw22_ram arv752dpw22_nor arv752dpw22_brn \
arv8539pw22_brn arv8539pw22_nor arv8539pw22_ram \
+ bthomehubv5a_ram \
gigasx76x_ram gigasx76x_nor \
acmp252_ram acmp252_nor \
easy50712_ram easy50712_nor easy50712_norspl \