aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-kirkwood/patches/008-nsa325-uboot-generic.patch
diff options
context:
space:
mode:
authorPaul Wassi <p.wassi@gmx.at>2018-03-13 17:25:20 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-03-20 21:45:27 +0100
commitf21cd9640052a733e1759519e3d7ca0f9453653b (patch)
tree5441029a3371926da96ce49ac8a74745f08b139e /package/boot/uboot-kirkwood/patches/008-nsa325-uboot-generic.patch
parent89b8ba96b404d2e412d5573e25348287255671dd (diff)
downloadupstream-f21cd9640052a733e1759519e3d7ca0f9453653b.tar.gz
upstream-f21cd9640052a733e1759519e3d7ca0f9453653b.tar.bz2
upstream-f21cd9640052a733e1759519e3d7ca0f9453653b.zip
uboot-kirkwood: update to 2018.03
U-Boot now requires GCC > 5 Catch up with upstream and move some configuration options from the header files to the corresponding defconfig files. Also move some options of patch 010 affecting the whole platform to 010's device only. Signed-off-by: Paul Wassi <p.wassi@gmx.at>
Diffstat (limited to 'package/boot/uboot-kirkwood/patches/008-nsa325-uboot-generic.patch')
-rw-r--r--package/boot/uboot-kirkwood/patches/008-nsa325-uboot-generic.patch42
1 files changed, 6 insertions, 36 deletions
diff --git a/package/boot/uboot-kirkwood/patches/008-nsa325-uboot-generic.patch b/package/boot/uboot-kirkwood/patches/008-nsa325-uboot-generic.patch
index 4b4356e5d5..fd6dd6fa36 100644
--- a/package/boot/uboot-kirkwood/patches/008-nsa325-uboot-generic.patch
+++ b/package/boot/uboot-kirkwood/patches/008-nsa325-uboot-generic.patch
@@ -1,5 +1,3 @@
-diff --git a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
-index 819bd3b..6a2d578 100644
--- a/arch/arm/mach-kirkwood/Kconfig
+++ b/arch/arm/mach-kirkwood/Kconfig
@@ -62,6 +62,9 @@ config TARGET_NSA310
@@ -19,9 +17,6 @@ index 819bd3b..6a2d578 100644
+source "board/zyxel/nsa325/Kconfig"
endif
-diff --git a/board/zyxel/nsa325/Kconfig b/board/zyxel/nsa325/Kconfig
-new file mode 100644
-index 0000000..1fe5ead
--- /dev/null
+++ b/board/zyxel/nsa325/Kconfig
@@ -0,0 +1,12 @@
@@ -37,9 +32,6 @@ index 0000000..1fe5ead
+ default "nsa325"
+
+endif
-diff --git a/board/zyxel/nsa325/MAINTAINERS b/board/zyxel/nsa325/MAINTAINERS
-new file mode 100644
-index 0000000..130b4d9
--- /dev/null
+++ b/board/zyxel/nsa325/MAINTAINERS
@@ -0,0 +1,6 @@
@@ -49,9 +41,6 @@ index 0000000..130b4d9
+F: board/zyxel/nsa325/
+F: include/configs/nsa325.h
+F: configs/nsa325_defconfig
-diff --git a/board/zyxel/nsa325/Makefile b/board/zyxel/nsa325/Makefile
-new file mode 100644
-index 0000000..4ee953b
--- /dev/null
+++ b/board/zyxel/nsa325/Makefile
@@ -0,0 +1,13 @@
@@ -68,9 +57,6 @@ index 0000000..4ee953b
+
+obj-y := nsa325.o
+
-diff --git a/board/zyxel/nsa325/kwbimage.cfg b/board/zyxel/nsa325/kwbimage.cfg
-new file mode 100644
-index 0000000..5a27d38
--- /dev/null
+++ b/board/zyxel/nsa325/kwbimage.cfg
@@ -0,0 +1,78 @@
@@ -152,9 +138,6 @@ index 0000000..5a27d38
+# End of Header extension
+DATA 0x0 0x0
+
-diff --git a/board/zyxel/nsa325/nsa325.c b/board/zyxel/nsa325/nsa325.c
-new file mode 100644
-index 0000000..4cd1c0f
--- /dev/null
+++ b/board/zyxel/nsa325/nsa325.c
@@ -0,0 +1,265 @@
@@ -423,9 +406,6 @@ index 0000000..4cd1c0f
+
+#endif
+
-diff --git a/board/zyxel/nsa325/nsa325.h b/board/zyxel/nsa325/nsa325.h
-new file mode 100644
-index 0000000..996653e
--- /dev/null
+++ b/board/zyxel/nsa325/nsa325.h
@@ -0,0 +1,77 @@
@@ -506,14 +486,12 @@ index 0000000..996653e
+#define BTN_COPY 37
+
+#endif /* __NSA325_H */
-diff --git a/configs/nsa325_defconfig b/configs/nsa325_defconfig
-new file mode 100644
-index 0000000..48e09cc
--- /dev/null
+++ b/configs/nsa325_defconfig
-@@ -0,0 +1,34 @@
+@@ -0,0 +1,37 @@
+CONFIG_ARM=y
+CONFIG_KIRKWOOD=y
++CONFIG_SYS_TEXT_BASE=0x600000
+CONFIG_TARGET_NSA325=y
+CONFIG_IDENT_STRING="\nZyXEL NSA325 2-Bay Power Media Server"
+CONFIG_BOOTDELAY=3
@@ -536,6 +514,7 @@ index 0000000..48e09cc
+CONFIG_CMD_EXT4=y
+CONFIG_CMD_FAT=y
+CONFIG_CMD_JFFS2=y
++CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0x0c0000(uboot),0x80000(uboot_env),0x7ec0000(ubi)"
+CONFIG_CMD_MTDPARTS=y
+CONFIG_CMD_ENV=y
+CONFIG_CMD_NAND=y
@@ -546,12 +525,10 @@ index 0000000..48e09cc
+CONFIG_USB_STORAGE=y
+CONFIG_LZMA=y
+CONFIG_LZO=y
-diff --git a/include/configs/nsa325.h b/include/configs/nsa325.h
-new file mode 100644
-index 0000000..e5a8e2a
++CONFIG_SYS_LONGHELP=y
--- /dev/null
+++ b/include/configs/nsa325.h
-@@ -0,0 +1,129 @@
+@@ -0,0 +1,122 @@
+/*
+ * (C) Copyright 2016 bodhi <mibodhi@gmail.com>
+ *
@@ -603,7 +580,6 @@ index 0000000..e5a8e2a
+/*
+ * Commands configuration
+ */
-+#define CONFIG_SYS_LONGHELP
+#define CONFIG_PREBOOT
+
+/*
@@ -634,16 +610,10 @@ index 0000000..e5a8e2a
+ "ubi read 0x800000 kernel; " \
+ "bootm 0x800000"
+
-+#define CONFIG_MTDPARTS \
-+ "mtdparts=orion_nand:" \
-+ "0x0c0000(uboot)," \
-+ "0x80000(uboot_env)," \
-+ "0x7ec0000(ubi)\0"
-+
+#define CONFIG_EXTRA_ENV_SETTINGS \
+ "console=console=ttyS0,115200\0" \
+ "mtdids=nand0=orion_nand\0" \
-+ "mtdparts="CONFIG_MTDPARTS \
++ "mtdparts="CONFIG_MTDPARTS_DEFAULT \
+ "bootargs_root=\0"
+
+/*