aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-imx6/Makefile
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2018-11-26 23:31:53 +0100
committerPetr Štetiar <ynezz@true.cz>2019-04-08 18:37:03 +0200
commit136001675e09d1288cdbb4302ac2455a4655ba32 (patch)
treea61cac4803dba9a86577784a793670a808feaced /package/boot/uboot-imx6/Makefile
parent8f1cbef12ee5ae7e48830128425ca555500b87f6 (diff)
downloadupstream-136001675e09d1288cdbb4302ac2455a4655ba32.tar.gz
upstream-136001675e09d1288cdbb4302ac2455a4655ba32.tar.bz2
upstream-136001675e09d1288cdbb4302ac2455a4655ba32.zip
uboot-imx6: Add support for Toradex Apalis board family
This patch is needed in order to properly boot OpenWrt bootscript. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package/boot/uboot-imx6/Makefile')
-rw-r--r--package/boot/uboot-imx6/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/boot/uboot-imx6/Makefile b/package/boot/uboot-imx6/Makefile
index 25d68bf6ca..f431afc525 100644
--- a/package/boot/uboot-imx6/Makefile
+++ b/package/boot/uboot-imx6/Makefile
@@ -20,6 +20,12 @@ define U-Boot/Default
UBOOT_IMAGE:=u-boot.imx
endef
+define U-Boot/apalis_imx6
+ NAME:=Toradex Apalis
+ UBOOT_IMAGE:=SPL u-boot.img u-boot-with-spl.imx
+ UBOOT_MAKE_FLAGS:=SPL u-boot.img u-boot-with-spl.imx
+endef
+
define U-Boot/mx6cuboxi
NAME:=SolidRun Cubox-i boards
UBOOT_IMAGE:=SPL u-boot.img
@@ -62,6 +68,7 @@ define U-Boot/wandboard
endef
UBOOT_TARGETS := \
+ apalis_imx6 \
mx6cuboxi \
mx6sabresd \
nitrogen6dl \