aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-fritz4040/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-05-17 21:32:50 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-05-19 12:29:24 +0200
commitdf6e8c8771d5457048a5cb1e510c6bc73bd4c173 (patch)
tree4d24f6da75c6fbab955b48b4812e657d4e6dec1d /package/boot/uboot-fritz4040/Makefile
parent2d0c0abf5d98d1f85f9d5253e0162383c33200a6 (diff)
downloadupstream-df6e8c8771d5457048a5cb1e510c6bc73bd4c173.tar.gz
upstream-df6e8c8771d5457048a5cb1e510c6bc73bd4c173.tar.bz2
upstream-df6e8c8771d5457048a5cb1e510c6bc73bd4c173.zip
uboot-fritz4040: Add host flags for host compiler
This adds the host staging directory to the include path to make it use the zlib.h files from the staging include directory and also link against the zlib version from the staging directory. This fixes a compile problem when the zlib header were not installed on the build host. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [picked from openwrt-18.06]
Diffstat (limited to 'package/boot/uboot-fritz4040/Makefile')
-rw-r--r--package/boot/uboot-fritz4040/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/boot/uboot-fritz4040/Makefile b/package/boot/uboot-fritz4040/Makefile
index c6f0cab8c4..df9c685c95 100644
--- a/package/boot/uboot-fritz4040/Makefile
+++ b/package/boot/uboot-fritz4040/Makefile
@@ -46,8 +46,8 @@ export DTC
define Build/Configure
$(Build/Configure/U-Boot)
- $(HOSTCC) -o $(PKG_BUILD_DIR)/fritz/lzma2eva $(PKG_BUILD_DIR)/fritz/src/lzma2eva.c
- $(HOSTCC) -o $(PKG_BUILD_DIR)/fritz/tichksum $(PKG_BUILD_DIR)/fritz/src/tichksum.c
+ $(HOSTCC) $(HOST_CFLAGS) $(HOST_LDFLAGS) -o $(PKG_BUILD_DIR)/fritz/lzma2eva $(PKG_BUILD_DIR)/fritz/src/lzma2eva.c -lz
+ $(HOSTCC) $(HOST_CFLAGS) $(HOST_LDFLAGS) -o $(PKG_BUILD_DIR)/fritz/tichksum $(PKG_BUILD_DIR)/fritz/src/tichksum.c
ln -sf $(STAGING_DIR_HOST)/bin/lzma $(PKG_BUILD_DIR)/fritz
endef