aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-envtools/patches/001-compile.patch
diff options
context:
space:
mode:
authorLuis Araneda <luaraneda@gmail.com>2018-04-06 11:23:34 -0300
committerHauke Mehrtens <hauke@hauke-m.de>2018-04-18 23:59:32 +0200
commit68150d3125447a40cf103aeefd9bcb6c874e6769 (patch)
treee2c78ddaccb31c4da0dc874a0d412f5332b63233 /package/boot/uboot-envtools/patches/001-compile.patch
parent7b758f7f4faceaea6b2d484658dfecd0e3ea3e23 (diff)
downloadupstream-68150d3125447a40cf103aeefd9bcb6c874e6769.tar.gz
upstream-68150d3125447a40cf103aeefd9bcb6c874e6769.tar.bz2
upstream-68150d3125447a40cf103aeefd9bcb6c874e6769.zip
uboot-envtools: update to 2018.03
Several changes has been made: + AES support has been removed by upstream commit c6831c7 (2017-11-14) [remove patch "200-fw_env_no_aes.patch"] + Support for UBI volumes has beed added by upstream commit 34255b9 (2017-11-15) [remove patch "300-support-env-in-ubivol-chardev.patch"] + A command line argument has beed added ("-c") to manually indicate the location of the environment configuration file Also, patch "400-u-boot-2015.10-stdint.patch" is no longer necessary, and the config option to enable UBI support has been removed. Size comparisons: fw_printenv size: Target Before After ar71xx 15,189 bytes 18,133 bytes (+2,944 bytes) ipq40xx 20,873 bytes 20,987 bytes (+114 bytes) mvebu 20,881 bytes 20,991 bytes (+110 bytes) ramips 15,128 bytes 18,072 bytes (+2,944 bytes) OPKG package size: Target Before After ar71xx 11,309 bytes 12,875 bytes (+1,566 bytes) ipq40xx 11,772 bytes 13,299 bytes (+1,527 bytes) mvebu 11,609 bytes 13,114 bytes (+1,505 bytes) ramips 10,975 bytes 12,503 bytes (+1,528 bytes) Compile tested: ipq40xx (musl, glibc, gcc5-musl), ar71xx, mvebu, ramips Run tested: ipq40xx (ASUS RT-AC58U) Signed-off-by: Luis Araneda <luaraneda@gmail.com>
Diffstat (limited to 'package/boot/uboot-envtools/patches/001-compile.patch')
-rw-r--r--package/boot/uboot-envtools/patches/001-compile.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/boot/uboot-envtools/patches/001-compile.patch b/package/boot/uboot-envtools/patches/001-compile.patch
index 1705979765..f7ec9130d6 100644
--- a/package/boot/uboot-envtools/patches/001-compile.patch
+++ b/package/boot/uboot-envtools/patches/001-compile.patch
@@ -2,7 +2,7 @@
+++ b/tools/env/Makefile
@@ -10,6 +10,10 @@
# with "CC" here for the maximum code reuse of scripts/Makefile.host.
- HOSTCC = $(CC)
+ override HOSTCC = $(CC)
+ifneq ($(TARGET_CFLAGS),)
+HOSTCFLAGS = $(TARGET_CFLAGS)