aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-at91
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2018-05-04 10:27:51 -0700
committerJohn Crispin <john@phrozen.org>2018-05-05 06:55:22 +0200
commit27ca6cdc7bb3e01d12ed4cf6a3cc5b2b11c516de (patch)
treec45a3a4b9fada7c1cf3f2966b8d9afdfa14e65b3 /package/boot/uboot-at91
parent60750ab505bae8d1cb70c6fe495b755b213a1ebf (diff)
downloadupstream-27ca6cdc7bb3e01d12ed4cf6a3cc5b2b11c516de.tar.gz
upstream-27ca6cdc7bb3e01d12ed4cf6a3cc5b2b11c516de.tar.bz2
upstream-27ca6cdc7bb3e01d12ed4cf6a3cc5b2b11c516de.zip
at91: Add SAMA5D2 PTC EK board
Add target device as at91-sama5d2_ptc_ek in SAMA5D2 subtarget and build images for SAMA5D2 PTC Ek board. Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'package/boot/uboot-at91')
-rw-r--r--package/boot/uboot-at91/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index fd58b9009e..f0a4ba56c2 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -21,7 +21,7 @@ include $(INCLUDE_DIR)/kernel.mk
define U-Boot/Default
BUILD_TARGET:=at91
HIDDEN:=1
- UBOOT_IMAGE:=u-boot.bin boot.bin
+ UBOOT_IMAGE:=u-boot.bin
endef
define U-Boot/at91sam9m10g45ek_nandflash
@@ -92,6 +92,18 @@ define U-Boot/sama5d27_som1_ek_spiflash
BUILD_DEVICES:=at91-sama5d27_som1_ek
endef
+define U-Boot/sama5d2_ptc_ek_nandflash
+ NAME:=SAMA5D2 PTC Ek (Nand Flash)
+ BUILD_SUBTARGET:=sama5d2
+ BUILD_DEVICES:=at91-sama5d2_ptc_ek
+endef
+
+define U-Boot/sama5d2_ptc_ek_mmc
+ NAME:=SAMA5D2 PTC Ek (SDCard)
+ BUILD_SUBTARGET:=sama5d2
+ BUILD_DEVICES:=at91-sama5d2_ptc_ek
+endef
+
UBOOT_TARGETS := \
at91sam9m10g45ek_nandflash \
at91sam9x5ek_nandflash \
@@ -103,7 +115,9 @@ UBOOT_TARGETS := \
sama5d4_xplained_spiflash \
sama5d4_xplained_nandflash\
sama5d27_som1_ek_mmc \
- sama5d27_som1_ek_spiflash
+ sama5d27_som1_ek_spiflash \
+ sama5d2_ptc_ek_nandflash \
+ sama5d2_ptc_ek_mmc
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \