aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-at91/Makefile
diff options
context:
space:
mode:
authorSandeep Sheriker M <sandeep.sheriker@microchip.com>2019-08-14 00:42:14 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2019-08-17 23:08:10 +0200
commitb39dc6e550f7aa2f6870204670e9adaff4ebc68f (patch)
tree57655737dedb1cfe088ca6bbfb69ede34e236e3e /package/boot/uboot-at91/Makefile
parentadc69febc0e2d48810383e12bcd4ae03fe9feefc (diff)
downloadupstream-b39dc6e550f7aa2f6870204670e9adaff4ebc68f.tar.gz
upstream-b39dc6e550f7aa2f6870204670e9adaff4ebc68f.tar.bz2
upstream-b39dc6e550f7aa2f6870204670e9adaff4ebc68f.zip
uboot-at91: fix -Wformat-security
add patch to fix -Wformat-security warnings. Signed-off-by: Sandeep Sheriker M <sandeep.sheriker@microchip.com>
Diffstat (limited to 'package/boot/uboot-at91/Makefile')
-rw-r--r--package/boot/uboot-at91/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index c17f1e04bf..547b72f8d9 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -131,7 +131,7 @@ UBOOT_TARGETS := \
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CROSS_COMPILE=$(TARGET_CROSS) \
- DTC=$(LINUX_DIR)/scripts/dtc/dtc \
+ DTC=$(PKG_BUILD_DIR)/scripts/dtc/dtc \
KCFLAGS="$(filter-out -fstack-protector \
-mfloat-abi=hard, $(TARGET_CFLAGS)) -mfloat-abi=soft"
endef