aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/at91bootstrap/Makefile
diff options
context:
space:
mode:
authorClaudiu Beznea <claudiu.beznea@microchip.com>2022-02-04 15:24:55 +0200
committerPetr Štetiar <ynezz@true.cz>2022-02-24 19:05:28 +0100
commitbf13b2da2a2336662ac9a7a9952add19557ef935 (patch)
tree4caecc6d13d8616cc900788bd35c356994422c47 /package/boot/at91bootstrap/Makefile
parente040d31177b1507ccac965adc18f2e968310b5c3 (diff)
downloadupstream-bf13b2da2a2336662ac9a7a9952add19557ef935.tar.gz
upstream-bf13b2da2a2336662ac9a7a9952add19557ef935.tar.bz2
upstream-bf13b2da2a2336662ac9a7a9952add19557ef935.zip
at91bootstrap: update to v3.10.4, v4.0.1
AT91Bootstrap version 4 is available only for SAM9X60, SAMA5D2, SAMA5D3, SAMA5D4, SAMA7G5. Thus use v4.0.1 for the above targets and v3.10.4 for the rest of them. With the switch to v4 AT91Bootstrap binaries are now on build/binaries. Take also this into account. Also, patches directory is not needed anymore with the version update. Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
Diffstat (limited to 'package/boot/at91bootstrap/Makefile')
-rw-r--r--package/boot/at91bootstrap/Makefile24
1 files changed, 21 insertions, 3 deletions
diff --git a/package/boot/at91bootstrap/Makefile b/package/boot/at91bootstrap/Makefile
index 2d77f70997..92dbf27a1e 100644
--- a/package/boot/at91bootstrap/Makefile
+++ b/package/boot/at91bootstrap/Makefile
@@ -9,13 +9,31 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=at91bootstrap
-PKG_VERSION:=v3.9.3
+PKG_VERSION:=v4.0.1
+PKG_MIRROR_HASH:=3d45a4bcb52162097d4cdf042b8fe1ccf53e88b512e7541f42a23f2a73692a69
+PKG_SOURCE_VERSION:=4d41296e9ae12379555fb46a941897e7264600a2
+BINARIES_DIR:=build/binaries
+
+AT91BOOTSTRAP_V4=y
+ifdef CONFIG_PACKAGE_at91bootstrap-sama5d4_xplaineddf_uboot_secure
+ AT91BOOTSTRAP_V4=n
+else ifdef CONFIG_TARGET_at91_sam9x
+ ifndef CONFIG_TARGET_at91_sam9x_DEVICE_microchip_sam9x60ek
+ AT91BOOTSTRAP_V4=n
+ endif
+endif
+
+ifeq ($(AT91BOOTSTRAP_V4),n)
+ PKG_VERSION=v3.10.4
+ PKG_MIRROR_HASH=6fe61fe90838e785917383bb9e887fa05e1bd061a6725954242f504e38b5c426
+ PKG_SOURCE_VERSION=404846dd283894367a015ca59189bcf927d92e11
+ BINARIES_DIR=binaries
+endif
+
PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/linux4sam/at91bootstrap.git
-PKG_MIRROR_HASH:=06753d673756edc9753932db00f4e5b8c1f9fa7708337c4d6ce280573efb86b4
-PKG_SOURCE_VERSION:=d96833a4b6680b237708eb4dc9f10708b9e709d8
PKG_BUILD_DIR = \
$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)