aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/at91bootstrap/Makefile
diff options
context:
space:
mode:
authorClaudiu Beznea <claudiu.beznea@microchip.com>2021-10-11 11:47:26 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2021-10-24 18:52:29 +0200
commit8746ba3657b2c328ad23a6adcbe5fb6a9e87c490 (patch)
tree7ca9c3f5627cfc51de1ea8ea66c9918a3c0f9313 /package/boot/at91bootstrap/Makefile
parent65c4e89dcf01ca5e4ab3e5c2564fb8ca42757f8c (diff)
downloadupstream-8746ba3657b2c328ad23a6adcbe5fb6a9e87c490.tar.gz
upstream-8746ba3657b2c328ad23a6adcbe5fb6a9e87c490.tar.bz2
upstream-8746ba3657b2c328ad23a6adcbe5fb6a9e87c490.zip
at91: add support for sam9x60-ek board
Add support for SAM9X60-EK board. Hardware: - SoC: SAM9X60 - RAM: Winbond W972GG6KB-25 (2Gbit DDR2) - NAND Flash: Micron MT29F4G08ABAEA - QSPI Flash: Microchip SST26VF064B - EEPROM: Microchip 24AA02E48 - SDMMC: One standard 4-bit SD card interface - USB: two stacked Type-A connectors with power switches, one micro-B USB device - CAN: 2 interfaces (Microchip MCP2542) - Ethernet: one 10/100Mbps - WiFi/BT: one optional WiFi/Bluetooth interface - Audio: one ClassD port - Display: one 24-bit LCD interface - Camera: one 12-bit image sensor interface - IO: one IO expander (Microchip MCP23008) - Debug ports: one J-Link-OB + CDC, one JTAG interface - Leds: one RGB LED - Buttons: 4 push button switches - Expansion: one PIO connector, one mikrobus connector - Power management: two power regulators, two power consumption measurement devices Flashing: - follow the procedure at [1] [1] https://www.linux4sam.org/bin/view/Linux4SAM/Sam9x60EKMainPage#Create_a_SD_card_with_the_demo Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
Diffstat (limited to 'package/boot/at91bootstrap/Makefile')
-rw-r--r--package/boot/at91bootstrap/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/boot/at91bootstrap/Makefile b/package/boot/at91bootstrap/Makefile
index 8711acd286..2d77f70997 100644
--- a/package/boot/at91bootstrap/Makefile
+++ b/package/boot/at91bootstrap/Makefile
@@ -40,6 +40,18 @@ define AT91Bootstrap/at91sam9x5eksd_uboot
BUILD_DEVICES:=atmel_at91sam9x25ek atmel_at91sam9x35ek
endef
+define AT91Bootstrap/sam9x60eknf_uboot
+ NAME:=AT91Bootstrap for SAM9X60-EK board (NandFlash)
+ BUILD_SUBTARGET:=sam9x
+ BUILD_DEVICES:=microchip_sam9x60ek
+endef
+
+define AT91Bootstrap/sam9x60eksd_uboot
+ NAME:=AT91Bootstrap for SAM9X60-EK board (SDcard)
+ BUILD_SUBTARGET:=sam9x
+ BUILD_DEVICES:=microchip_sam9x60ek
+endef
+
define AT91Bootstrap/sama5d2_icpdf_qspi_uboot
TITLE:=AT91Bootstrap for SAMA5D2 ICP board (QSPI Flash)
BUILD_SUBTARGET:=sama5
@@ -145,6 +157,8 @@ endef
AT91BOOTSTRAP_TARGETS := \
at91sam9x5eknf_uboot \
at91sam9x5eksd_uboot \
+ sam9x60eknf_uboot \
+ sam9x60eksd_uboot \
sama5d2_icpdf_qspi_uboot \
sama5d2_icpsd_uboot \
sama5d2_xplaineddf_uboot \