aboutsummaryrefslogtreecommitdiffstats
path: root/package/bcm43xx-mac80211/src/bcm43xx/Makefile
diff options
context:
space:
mode:
authorPeter Denison <openwrt@marshadder.org>2007-06-21 20:45:45 +0000
committerPeter Denison <openwrt@marshadder.org>2007-06-21 20:45:45 +0000
commit45a0adebf92dae844fde1588b452183c409cb0ea (patch)
treed12a3cdaab17b15bb700d369b9ba0cfc2a157621 /package/bcm43xx-mac80211/src/bcm43xx/Makefile
parent65f00ab51a3d380ca9d87f35426a076a7f291e04 (diff)
downloadupstream-45a0adebf92dae844fde1588b452183c409cb0ea.tar.gz
upstream-45a0adebf92dae844fde1588b452183c409cb0ea.tar.bz2
upstream-45a0adebf92dae844fde1588b452183c409cb0ea.zip
New: mac80211-based bcm43xx driver from the wireless-dev tree
SVN-Revision: 7693
Diffstat (limited to 'package/bcm43xx-mac80211/src/bcm43xx/Makefile')
-rw-r--r--package/bcm43xx-mac80211/src/bcm43xx/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/bcm43xx-mac80211/src/bcm43xx/Makefile b/package/bcm43xx-mac80211/src/bcm43xx/Makefile
new file mode 100644
index 0000000000..ce66b7b724
--- /dev/null
+++ b/package/bcm43xx-mac80211/src/bcm43xx/Makefile
@@ -0,0 +1,18 @@
+obj-$(CONFIG_BCM43XX_MAC80211) += bcm43xx-mac80211.o
+
+bcm43xx-mac80211-obj-$(CONFIG_BCM43XX_MAC80211_PCMCIA) += bcm43xx_pcmcia.o
+
+bcm43xx-mac80211-obj-$(CONFIG_BCM43XX_MAC80211_DEBUG) += bcm43xx_debugfs.o
+
+bcm43xx-mac80211-obj-$(CONFIG_BCM43XX_MAC80211_DMA) += bcm43xx_dma.o
+bcm43xx-mac80211-obj-$(CONFIG_BCM43XX_MAC80211_PIO) += bcm43xx_pio.o
+
+bcm43xx-mac80211-objs := bcm43xx_main.o \
+ bcm43xx_tables.o \
+ bcm43xx_phy.o \
+ bcm43xx_power.o \
+ bcm43xx_sysfs.o \
+ bcm43xx_leds.o \
+ bcm43xx_xmit.o \
+ bcm43xx_lo.o \
+ $(bcm43xx-mac80211-obj-y)